Vacuum won't save map

Not Yet

I am in the same boat.
I don’t have an issue with its cleaning ability just it’s software app. In fact my unit won’t down the latest firmware…it just keeps spinning, saying “do not disconnect”. Went to bed and in the morning it was still spinning, and still not downloaded.
Call to Customer support resulted in 3hrs and still was no help.
Wyze needs a real tech support line…or detail training videos, and a better app.

APP Features Needed:

  1. This app needs the ability to save multiple room maps so you can divide the house into sections.
  2. Also have the ability to recall from a list which map to use it a larger home or upstairs / downstairs.
    3.Need a simple map edit feature so you have the ability to adjust boundary or modify vac path after the fact.
  3. Be able to select multi rooms from the a map list.

I shouldn’t have to create a new vac map ever time I want to vac a room…and that’s what it does now.


After a solid 10 days without a single hiccup and performing flawlessly, the vacuum now will not successfully run on the same map for more than one cleaning.

I have to delete the map every single day and place new virtual walls every single day. Going on 12 days waiting on a response to my support ticket.

@WyzeGwendolyn, can I message you my ticket number to get someone to respond?

Pretty impressed with the vacuum, everything seems to be working fine so far. Running latest firmware - 1.6.75. Thanks

The first time after reseting the map, it will redraw your floor plan and assign names to what it thinks are rooms. I had to place a few pillows in a wide entryway to get it to recognize my dining room as a separate room. Once you have some rooms,

o You have to tap to check a room name before you tap clean to clean just one room.
o You can also schedule a single room or multiple room.

Knock on wood, my floorpan, virtual walls & rooms haven’t disappeared

How did you setup individual room schedules. I finally for the vacuum to draw a complete map of my home. When I go to schedule it shows me a screen for starting time, how often and suction level but does not show a selection where I can select specific rooms.

Never mind, found the problem. The robot needed to have its firmware upgraded. Upgraded it and now I can select rooms !

1 Like

Welcome @DRESEN.HP, @gerutzen & @pauld315 to the community forum. :slightly_smiling_face:
Also welcome: @rcpostel, @wolfcorner, @skkyup & @craigfennessy

As @pauld315 & @mtsbst stated, there is a new F/W update 1.6.75 (December 17, 2020)

In addtion there is a new app to address additional troubles:


Thank you,
Important to be on the current updates when comparing notes.

1 Like

There is another vacuum f/w update just released 01/18/2021:

I am having the same issue with the map not saving. It took 5 days for me to Finally get a full clean and a full map and now it won’t save. How did you get yours to save the map?

Boy, I’m having the same problem and having to reset, then re-create the map each time. While the new firmware and app adds the much-needed room editing feature, I really haven’t been able to use it. If the vacuum gets stuck during mapping, or needs a bin change, it loses much/all of its map (or the map becomes corrupted and mis-drawn). Let’s hope Wyze is on this and help is on its way!

Not sure why my problem with the resetting map solved itself, but it did. And the next update that came made it more stable. There’s another update on its way that is even better. So stay tuned, I’m certain your issues may be related to the issues they’re working on

Download new firmware and it started mapping my rooms.

Vac cleaned rooms fine, However, there is no way to “save” room/ rooms, just cleaned.

Is there a “Save As” somewhere?
I need to recall in the future what areas it just mapped out.
It shows up in my history… but nowhere else.
I’m sorry, this app is just not very intuitive or functional.
From what I read… it should take my last mapping and break it down into sections. Using the latest firmware I should be able to recall and select what areas I want cleaned.

It does not do that!!

Has anyone resolved this issue?

I updated both SW on the app and FW on the vacuum, however, I still have issues with the vacuum getting lost and the progress it made to map gets deleted. I also still have issues with the lidar, and that the home is drawn in angles…and not 90 degrees. Basically causing the vacuum to get lost and not vacuum all the areas it should. I have deleted maps, removed and added the vacuum, and I still have not had a successful mapping of my home. I have had this crappy product for over a month, and have tried to vacuum my home, seriously over 30 times, and only once have I had a successful mapping only to have the vacuum get lost a few days later, along with the map. At this point, I am fed up with the product and have asked either for a refund or a new machine…as mine is definitely faulty.

1 Like

Hi @DRESEN.HP Have you opened up a support ticket? There should be a fix soon (tag below) or you may use the ticket to initiate a return.

Wyze Robot Vacuum Setup Issue - 1/25/21

1/25/21 10:00 AM PT - We are looking into an issue that is preventing Wyze Robot Vacuum setup for some customers. We apologize for the difficulty and will post updates here when we have them.


I have sent logs…I didn’t see where to submit an actual ticket in the app.

Hi @DRESEN.HP The logs aren’t reviewed unless associated with a Support Request. To create one call or fill out an eMail request. You should get an eMail reply with your ticket number.

Live support is available: +1-206.339.9646
Monday - Friday 5 am - 6 pm PT | Saturday 8 am - 4 pm PT

Or goto: (
You can start a chat session. To get the eMail request:

  • Just fill in a silly complaint (Kiwi ate my homework) and continue with NO answers until you finish the suggestions.
  • Eventually get to “Contact Support” & “EMAIL” prompt where you’ll be able to enter your trouble statement and contact info.

Having the same issues the vacuum maps the floor in various angles and ignores all virtual walls.

Raised multiple support tickets via app and none of them were replied too.

Got fed up with the product and submitted a return request was sent a generic set of instructions to troubleshoot and the request was closed. Extremely disappointed with product.

Update for both the customers and Wyze…I returned my vacuum. I gave it a month to work, trying to map over 35 times, and it just wasn’t worth the frustration. I purchased the Vacuum this one was copied from, and zero issues from day one, great room editing, and both vacuum and mop features!