V3 Firmware bricked

You may want to contact Wyze Customer Support about this issue!
By phone: (206) 339-9646 Available Monday - Friday 5 am - 6 pm PT and Saturday 8 am - 4 pm PT
Or online: Wyze.com/support (click “submit a request”)
phone support is typically faster however this isn’t always true due to fluctuation in the amount of calls.

Thanks I have good luck with Wyze customer service so far. My 1st v3 was replaced due to card reader not working. Reason why typically post even after I try to figure out to resolve on my own is to get more engagement with this community and share the issues.

I was hoping to solve this but I’m afraid my other v3 might start failing. What was weird is that my notifications video was looking like camera lens was pixelated in color and video was not viewable in part of the screen on app. That when I started to loose connection to the v3 shortly after.

I also have this issue, exactly the same symptoms as the OP.

Brand new camera delivered today, firmware completed first update earlier on, camera has been happy for a few hours.

Noticed another firmware update was due, started the update process and then couldn’t connect to the camera.

Checked the camera - solid red light. Power cycled (tried several times, including waiting in between), solid red light remains.

Downloaded a manual FW update file, but can’t kick the camera into updating as I never get the ‘purple’ coloured light after holding the setup button and powering on - it just goes straight to solid red.

Any ideas? Or is it going back to Amazon (from the UK!)

1 Like

The light won’t turn purple usually because it can’t find the FW file. Verify the file name.

1 Like

Thanks - yes that was the issue, this is why trying to fix things at 1am is never a good idea as I swear I had named it correctly.

Still no joy though however, so I’m fairly sure the camera is dead - it is now finding the firmware file and the light is changing from red to solid purple - then nothing happens.

I’ve tried all available firmware versions (125/228/252/280) and given each one at least 10 minutes to do something, but they all just sit there with the purple light on.

(I also found a previous post about the format of the firmware downloads changing at some point - so I’ve ALSO tried just renaming each downloaded file to ‘demo_wcv3.bin’ rather than extracting and renaming the content, but this resulted in the firmware file not being recognised - so no purple light.

I’ve checked the other 3 cameras I bought at the same time, each one completed all the firmward updates automatically without issue and are all now on the latest version 280.

Any other ideas before I return the single dead camera?

(the ONLY difference is that the original camera had an SD card present when the automatic update was applied and it died - the other 3 did not. Not sure if that is relevant or not.)

Long shot, but try power cycling the WiFi access point, and the ISP modem if a separate device.

Thanks for the suggestion, no joy unfortunately. Now being returned to Amazon.

This worked for me: I had updated the firmware on my v3 to but after rebooting the red light stayed on. I unplugged the spotlight, put the original power cable to the v3 and it booted up first time.
Unplugged it once more, put the spotlight cable splitter back in place. I connected the spotlight first to the cam and then the main power 2nd. The spot light stayed on and I couldn’t connect to the cam via the app. killed the app, tried again, same result.

I then connected just the spotlight to the power (via the splitter cable). The spolight came on, went through a couple of dimming and illuminating cycles and then the spot light went off.

I then connected the camera to the power (again via the splitter cable). Spotlight cycled, red light on cam came on. Spotlight went off, red light went off,

VOILA - Cam is working, but doesn;t detect spotlight.

Disconnected spotlight (via back of spotlight usb port) and plugged it back in, spotlight cycled then went off.

Everything i try either gets the cam working or the spotlight working but not both.

End of the day I got the cam back up and running and I’ll work on the spotlight when I have more patience.

Very interesting! I wonder if the addition of the spotlight software has been significant in all the reports of V3 bricking. The release of in Dec 2020 seems to be about the time bricking increased big time.

6 cam v3 purchased in April 4 bricked and we are in august… All cams are at That cam is a ticking time bomb. I have never witnessed such a high failure rate in my life.

I have 14 V3 cameras all are on and working. So far no issues here.

Can you flash them over again with via SD card to fix them?

I tried all sorts of firmware and manually load it, none worked. Camera LED turns “purple” but never restarts. Stock on a dead cycle.

1 Like

No matter how long I hold down setup, the solid red light never changed color.

1 Like

I was stuck here too. I reformatted the card to FAT in Disc Utility on a Mac. This finally got me to the purple light, but it just turns red after a few seconds and doesn’t reboot. ¯_(ツ)_/¯ this is so frustrating, and all Wyze support can do is send me another camera to brick.

1 Like

Request #2646916

BTW - you just revived a thread that had not seen a post for approximately 16 months.