V2 Firmware Update - Too dark at night - underexposed

Gradual release of new V3 firmware started today, you should be thrilled :rofl:

I figured it out how to change the name before downloading and saving. The question remains, does it download the older FW or the new with a different name? Only flashing it will confirm which one is I guess.

I bet it will brick at least one camera :rofl:

1 Like

In my case, I actually did d/l the older firmware some time back when I first saw the issue, but its strongly preferable to keep them updated for security rather than go backwards.
All this said, not expecting much as v2 cam support was officially stopped some time back and not even sold in store anymore. Its just unfortunate that this issue came up when it worked great before. Reminds me of Apple, “well you could always upgrade” (to Wyze credit they haven’t said that to me, just feels like it…) :thinking:

Instructions to download the old firmware files, but maybe Wyze doesn’t want you to know this …

  1. In your browser (Chrome, Firefox, etc), go to the official Wyze Release notes/Firmware page.
  2. Right click on the download link for the current firmware, and select the “Copy Link” or “Copy link address” option (depending on your browser).
  3. Paste that into the address bar of your browser, but do not press enter or click go, etc.
  4. Edit the link in your browser address bar to change the file name to the firmware version you want.
  5. Press enter or click go.
  6. If your browser is configured to prompt you for where to save it to and what name to save it as, save it to where ever you save downloads to. If you want to, you can change the name of the file to something else, but this will just confuse you when you go to find the file later on.
  7. If it says the file was not found, Wyze has changed the base file name back and forth a bit from version to version, and sometimes the file name ends with “.bin.zip”, and sometimes it just ends in “.zip”. Try adding or removing the “.bin” part from the file name to see if they have changed the name format between the current firmware and the version that you want.
  • For example, the V2 cam firmware file has “.bin” in the name and is called “demo_4.9.9.1433.bin.zip”, but the firmware does not and is just “demo_4.9.8.1002.zip”.

Note that you are not downloading the current firmware into a different file name, but this will download the firmware version that you put into your browser address bar, because that is the file that you are asking to download from Wyze.

If you want to confirm that it downloaded the proper firmware file (instead of the latest firmware with a different name), after you download the firmware file, you can double-click the downloaded file in your computer file manager, which will open the file as a zip archive file, and you can see that it contains the real binary firmware file from Wyze, which contains the firmware version number in the file name, and will be something like “demo_4.9.8.1002.bin”, or “demo_4.9.9.1433.bin”.

(Forum moderators: If you think that Wyze doesn’t want anyone to figure this out, then delete this post).


All this said, not expecting much as v2 cam support was officially stopped some time back and not even sold in store anymore.

You might be thinking of the original (V1) Camera, which you can’t buy from Wyze any more.

But the V2 camera is still for sale on the Wyze Products Shopping pages (Wyze Cam v2), and seems to still be supported from what I can see on all their web pages (but the web site does say that they are out of stock right now).

And you can still download the latest 3 versions of the V1 cam firmware from the Release Notes/Firmware download page (and older if you figure out the download link). And the latest V1 cam firmware was released 2 months ago, on 17 Aug 2022.

That is exactly what i did. Thanks for detailed info, I’m sure someone will find it helpful.

Easy direction for flashing after downloading what you want.

1 Like

Changing the name to save it to, will not download the proper firmware, but will just save the firmware to a different file name on your computer. You need to change the link that you are trying to download in your browser, not the name of the file it saves to. (see my other post with detailed instructions).

Like this :upside_down_face:

thx for the correction, my mistake on that, was thinking it was v2 not supported.

Like this :upside_down_face:

Yes, exactly. Change the name of the file to download to the version you want.

Note that the base name (the “demo_wcv3_” part) is different for each different camera, so start with the link to the current firmware for the camera you want, to get the base name part correct, then change the version number part of the file name.

And note that sometimes from one version to the next, Wyze adds “.bin.zip” at the end, and sometime it is just “.zip”. This happened for the V2 cam firmware with the latest firmware (they removed “.bin”)

I just opened the zip file that I downloaded and the bin file is created in Dec 2021. Your workaround definitely works.

Hope Wyze doesn’t remove it

You can only go back to (August 26, 2021). Older than that have been removed. I think this is good enough to do some testing. I’m thinking to buy a camera and keep it on my desk for sole purpose of testing things. Beats climbing up the ladder :slight_smile:

1 Like

Wonder if the WCO base station firmware is on there somewhere? I have tried editing the url, but never got it right… anyone know what it is?

Wyze!, anyone working on the update for the setting to stop going to default???

I’ve been using base firmware for the last 6 months without issues. Do you have issues?

WYZE! CAM V2 firmware needs help!
Please wyze! Anyone working on this? Wyze I’m pretty sure you know everything that’s going on and what’s wrong. Please we don’t need three scales! We would like more focus on the software/firmware.

You can actually go back clear to the first V3 firmware version, but there are 2 versions missing: and

Just skip those, and you can go back further.

The only links that I have seen, are for the cameras.

I suspect that this is because only the cameras have an SD card slot that is needed to manually install firmware. Without that, you can only update the firmware OTW (Over The Wire) by using the Wyze app, which is always going to update to the latest version.

Does the WCO base station have an SD card slot? There are firmware links for the WCO itself, but I have not see any links for the base station. The firmware might be there, but without a pattern/example, it will be nearly impossible to guess the base file name for the WCO base station.

The base file name for the cameras sort of make sense (once you see an example), but guessing those would still have been hit and miss. It might be easier to use a script that calls curl in a loop that tries various spellings. But even that would require thousands of guesses.