Update problem

I have been trying to update 1 of my cam v2 plus. Been trying for almost 24hrs. I won’t update. Can I get some help? BTW! The online chat for support is horrible. Just keep going around around in circle. Cant get to a support specialist. Just keeps asking me to rephrase my question. I WANNA TALK TO SOMEONE!!!

If you wish to speak to a Wyze employee/representative, you can call them at:

Wyze Customer Support: (206) 339-9646
Available Monday - Friday 4 am - 6 pm PT
Saturday 8 am - 4 pm PT
Sunday closed

Please note that Wyze Customer Support may still be affected by Super Typhoon Rai. They have been operating under limited hours with reduced staffing. If they are still under limited operations, wait times may be long and hours may vary.


This is a community forum where a number of individuals try to help each other. You can call Support at (206) 339-9646 Available Monday - Friday 4 am - 8 pm PT and Saturday 8 am - 4 pm PT.

Couple of questions

  • What version of the app are you using?
  • What Device are you using
  • What is the Firmware of the v2 you are trying to update? Current Production FW version is:

Confirming, you are trying to update a Cam V2 to the latest Firmware, correct? Asking as I am unsure as to what you mean by “plus”. Here is what I would do:

  • Remove the power from the Camera and wait for about 1 minute, then plug it back the power in
  • As the camera is booting up go to Account > App Setting in the app and select Clear Cache
  • Back out to the Account Menu, scroll to the bottom and log out
  • Reboot the phone or device you are using

Doing these steps to ensure things are cleared out before proceeding.

When the Device boots up, log back into the App, go to the Camera and select it to live stream the camera. Go to the Settings menu by select the gear at the top right of the live stream. Go to the Device Info Menu, click on Firmware and see if there is an update. you should be prompted to update the Firmware, if one is available.

1 Like

I signed out. now I cant sign back in

It should be your Wyze Username and Password. What are you seeing or prompts?

I just reset my password. well I am trying the update for my camera again. Keep getting “update failed” “reboot your wizen cam v2”

What is your current firmware?

you can also try to load the new FW via an SD Card.

you can go here to get the Firmware, expand the Cam v2 the click on the latest FW and it will download as a .zip file:

here are the steps to manually flash

updating again for the 20th time. this is more difficult then changing spark plugs on a ford.

1 Like

When I have issues, resetting the camera and clearing of the cache normally works. But it has never been what you are experiencing.

You can submit a log and open a ticket and post it here. Then we can see about tagging someone from Wyze.

oops sry about the deleting. Trying to update the camera through bluestacks. the update is 498.8.860.

My apologies, IMHO, you should be updating the FW via the Wyze App directly and not through Bluestack. I have used emulators in the past and there are some potential issues with doing things like this.

Can you try doing it through the Wyze App via your phone or tablet and not through Bluestack?

ooo I have tried and tried and tried via iPhone, iPad. I was trying through bluestack for humor. I may have to flash it. really don’t wanna. just a big pain my rear lol

1 Like

At this point, I would flash it. :slight_smile:


Call wise on Monday when they open,have you tried the sign out of app,sign back in and re boot your router/wifi system,and hard boot the camera, customer system will asked you all those questions we had a V2 that wouldn’t take the firmware update, we just did a month later with no isses

thanks everyone. I reflashed it. all is well. Sorry for my rudeness yesterday.

1 Like