Unbricking Wyze Contact Sensor - pcb reset pin

Wow so you’re saying it just uses whatever micro-USB or similar port that is on the device. Nice.

It’s not universal that they hang or brick due to low voltage though. I have some sensors that have gone through a few battery changes after going dead. Maybe it’s a certain sequence of events or what state the sensors happen to be in at the time the battery drops to a certain level.

yes that could possibly be the key, the state the sensor was in when battery dropped.
the Advisory mentions something on these lines.

What i noticed as well as the bricked sensors still give low battery flashes if you replace with a low battery instead of a fresh one. So something is running on the chip.

The advisory states that if you’re using a non-rechargeable battery (which I believe we all are) and the battery goes dead, simply replacing it will cause a POR eliminating the need for a workaround. Problem is, replacing the battery does not seem to resolve the issue so I don’t believe this advisory is relevant.

I would have thought Wyze had resolved this problem by now. I guess they aren’t focused on PR and quality nearly as much as introducing new products. But who’s going to buy them if they have a reputation for selling self-destructing products?


the flash on the contact sensors can be rewritten with a donor firmware via jtag. a guy on github has already done it successfully–do a search for ‘wyzeback’. aparently you need to reprogram the original mac or it won’t work.

bricked sensors continue to work in home assistant, but only as a group together–not distinguishable individually which is fine for my alarm system which sounds a siren with no regard to which sensor was tripped.


Ladies & gentlemen, I think a key piece of information has just been revealed:

btw HA - home assitant requires you add a laptop/tablet etc to your home Wyze setup to host the HA services

If a third party, HA, wrote code that can talk to these sensors, what is keeping Wyze from issuing an update so that we can keep using ours (grouped collectively in 1 sensor group per bridge) with the Wyze app ?

1 Like

That wyzeback looks really promising. I have a Launchpad (LM4F120XL), but not the same as the one he used. It looks like mine has an on-board jtag programmer too. Never used it though. Hmm…

If they did, I imagine that would be admitting that some of these sensors are defective and should have been recalled.

1 Like

Well, that, and he pretty clearly says they still don’t have unique MACs, so it wouldn’t help get them working properly again in the Wyze ecosystem.

to clarify, I have not unbricked my contact sensors. I continue to use them in home assistant with a null 00000000 mac address as a single group. I only pair 1 sensor and the rest of them can automatically communicate with the bridge. if a neighbor within radio range uses wyze sense it could be an issue.


Isn’t it possible to force a downgrade of the update on the bridge from version 0.33 back to 0.30? I mean, I had a new combo sensor set that came with two door sensors and a motion sensor. I bought it a year ago and just opened it last week and tried to hook it up. Nothing would work or light up. Checked the batteries and they were all dead. Seems kind of quick to die being that they were never used and sat in a box for almost 12 months. I ordered new ones from Amazon over night (love that). I reinstalled them and again tried to connect the motion sensor and it would not light up when resetting the pin and of course I tested the new batteries and they were full. Then tested the door sensors and they worked and blinked 3 times but still wouldn’t connect. I figured that it had to be the bridge that failed and wondered if it was the update for it that was the point of failure since I read on their update page that the only thing the update did was prevent the reset button on the back of the bridge to work. Why go thru the trouble of taking that off line, I don’t know. But, this problem isn’t isolated obviously so why hasn’t Wyze address this issue at all?

Well they “addressed” it by entirely dumping the product line and beginning to sell an entirely new series of sensors and bridge…

1 Like

This is an interesting point. If the bricking problem is partially the fault of the bridge firmware, then maybe the new Hub will allow some of the old “bricked” sensors to work again since the sensors will work on the hub which has different firmware.

I do feel for those who have bricked sensors, but I can’t exactly relate. I have had several sensors go “dead” and when I just put in a new battery, they start working again as normal. I am not sure why some get “bricked” and others are fine with it though (the only exception being the 1 sensor that went through the washing machine and came out with corrosion and rust throughout the entire thing afterward).

Oh great, well that helps…

I was perusing an old thread and came across a post by a Wyze employee about resetting a door sensor.

It worked on one of my problem ones, so I thought it might be worth a try for you folks:

The interesting trick was pushing the reset button 3 times while the battery was removed?

Well I did get one to pair, but then it did not work properly (open and close with magnet), so I deleted it and never could add it back. Oh well.
No matter what I do after replacing the battery it blinks twice.


i have the exact same issue, i tried everything to make it pair/work and not happening. I have multiple cams so tried with all of them…no, not working… so dissapointed :frowning:

I have some bricked contact sensors which flash when a battery is inserted but never connect with the sensor bridge. I assume these are the ones which report a 00000000 MAC address. I have several more bricked contact sensors which don’t flash at all when the battery is inserted. I assume these have more significant problems than the MAC address. All sensors worked properly at one point.

I tried using the method posted above which required the use of a sensor bridge with firmware version 0.30. That didn’t recover any of the sensors.

I also tried using the other method posted more recently which entailed pushing the reset button three times. I tried the three presses both with a battery in and out (the battery out method doesn’t make sense since the sensor won’t detect any reset button presses when it has no power). This method also did not recover any sensors.

I think the technique mentioned above by stanwebber is the only real solution (GitHub - sycophantic/wyzeback: A way to unbrick Wyze Sense sensors). And that requires the user to spend $30 + $5 shipping on a debug kit. But if you have several bricked sensors or anticipate them becoming bricked (as everyone reasonably should), then it may not be a bad investment.

I also tried using the other method posted more recently which entailed pushing the reset button three times. I tried the three presses both with a battery in and out (the battery out method doesn’t make sense since the sensor won’t detect any reset button presses when it has no power). This method also did not recover any sensors.

Kind of makes sense, the goal here might be to discharge any capacitors in the circuit.

I went through all 7 defunct contact sensors, and was only able to recover 1. I went ahead and put the working one back into service to see if it would maintain connectivity. It is a shame there is no way to recover any of these. The secondary market for sensor kits on EBAY has gone way up in price too (close to $40 shipped)!

precisely, whats making this difficult is we have no schematic from Wyze to help us figure out which capacitor is keeping this powered