Timelapse videos stop recording at 2048MB file size

I have been trying to record extended timelapse videos with several WyzeCam V2 units and keep getting the same problem: The camera stops recording timelapse when the file size reaches 2048MB. The timelaps function still shows that it is recording (square box), but the actual recording stops after 2048MB.

Even worse, if I let it go for a really long time (5 or 6 days recording at 6-second intervals), they not only stop recording, but, the timelapse ends with nothing saved to the Album.

I have tested this on six different WyzeCams V2; tried reformatting the microSD cards three different ways (Windows, Mac, and Wyzecam camera), but get the same problem every time. I contacted tech support a few months ago and they said they were working on it.

If anyone is willing to test this on their system, I would appreciate it. Perhaps it is something about my setup. I am recording timelapse at HD resolution, duration of a week or so, recoding frames at 6-second intervals. Any help or advice will be appreciated.


How is your microSD card formatted? FAT16, FAT32, etc. FAT16 max file size is 2GB, FAT32 max file size is 32GB, etc.

what firmware are you running on your camera? this issue has come up in the past but I believe was solved with a past update. make sure to submit logs with the issue as well. this way it can be tracked if it is a widespread issue again.

FAT32 has a maximum file size of 4GB.

exFAT has a maximum file size of 16 exabytes and works well for Wyze V2 cam recording.


Thanks for the correction, can’t believe I typed 32GB. :flushed: Sounds like exFAT would be the best option in this situation. Am curios since I’ve never checked … when formatting via the app, what format is used?

1 Like

when the app is used it is FAT32.

exfat is something you will have to do on a computer, there is no option to change it on the app.

1 Like

I just tried the following test:
–removed the SD card from one of my WyzCam V2 (Sandisk Ultra 32GB), formatted it in my Windows 10 desktop to default FAT32.
–Copied a single 3.8GB video file from my desktop to the Sandisk card. No problem. The single file appears on and is playable from the SD card.
So it appears to me that my problem is not likely due to the type of format? Am I missing something?

FAT32 should work for time lapse assuming the file size is 4GB or less, but … for anything larger, format on your PC to exFAT, per posts from @sodcam and @Bam above

1 Like

But my Wyzecams V2 all stop recording timelapse videos at 2048MB.
I will try an exFAT as you suggest.

Try one more time, using the SD Card Association formatter which you can download for free. SanDisk and most major SD card makers belong. This has worked for me when other formatters failed.


I did one time lapse with my first V2 just to prove it could be done, but it was not a memorable experience good or bad. So I am NOT an expert on time lapse!

I began having some issues with SD cards awhile back - stuttering and gaps in the continuous recording - usually during critical events. It may have had to do with trying to continually record to the SD card while uploading the 12 sec clip over a bad connection, or bad cards, or any number of things.

I wanted to go to larger SD cards anyhow, and someone mentioned using exFAT instead of FAT32 because of the larger cluster size. 64 GB seemed a good balance of size vs cost, so I went to them and have bought only the Samsung High Endurance cards designed for dash & body cams since. I fully (NOT quick) format every new card in a PC just using Windows 10 File Explorer.

So I changed a number of variables at once, but haven’t had many sd card issues since, so that’s what I keep doing! :grinning:

But if I ever hit any problems again, I will use the formatter that @desertshores recommended! :+1:

And yes just for the record, Wyze only officially supports 32GB cards & FAT32 format. And for flashing firmware, that is a must. Otherwise I would rather have a week of footage instead of just three days. :slightly_smiling_face:

Just set up a cam tonight and put in a new 64GB exFAT card, then reformatted it in the app and now it is FAT32. The funny thing is that it takes longer than a PC “quick format” but nowhere near as long as a PC “full format”, so I guess it has to do some sector checking - which is probably the important part! :+1: If it starts to stutter I’ll reformat it, otherwise let it be…

1 Like

For 24-hour timelapse, I recommend 5-second interval. I tried the default 3-second interval and it stopped recording several hours before the end time. Interestingly, another camera doesn’t have such issue. I tried several solutions, such as reformat the SD card within the app, stop the continuous recording to have enough space for the timelapse, and unplug the camera and plugin several hours later. The last solution solved the issue, kind of. However, I have to do this every single day. Otherwise, the issue keeps coming back. Therefore, I decided to just change the interval to 5-second.

Hopefully Wyze can allow us to change the default timelapse interval in the future, and/or solve this issue of ending timelapse early in the camera.

P.S. I forgot to mention that during the time when the timelapse footage was missing, the app still stated the timelapse is in progress.

1 Like

Thank you for the confirmation! That sounds incredibly reminiscent of the one day that I tried out the time lapse feature. I may give it another chance now! :+1: :slightly_smiling_face:

Good to know, but what if it is long term 7 days or even continuos, should it be 5 sec or different setting?

its really all about what you are trying to capture, if it is snowfall or something like that, the fast frame rate usually works better, but the longer a lapse goes typically you want to lessen the frame rate…unless the subject of the lapse would suffer from the intermittent frames. the key is playing with the frame rate and finding out what works for your subject material.

for instance I was trying to time lapse the color change in the fall of the big trees in my back yard over the course of a month. I THINK ( not terribly sure i remember correctly) my frame rate was every hour or half hour during the daytime.

a useful thing discovered by the @Mavens when this first issue came about was that if you use a schedule to turn off your camera, say at night and turn it back on in the morning during daylight while you are doing a time lapse the time lapse will automatically stop and restart and you will not have to edit out all the hours of nighttime during which you can’t see anything


Thanks for the wonderful tip :slight_smile:


Glad to help!


I recall reading about some counterfeit SD cards. They were major brand cards purchased on Amazon and looked exactly like the real thing. They were labeled as large capacity cards and showed up as such when checking. They could be formatted in a pc, with the report stating that the card had been formatted to the correct size, when in reality it hadn’t - very sophisticated.
You can google counterfeit sd cards for more information, and there are some programs that will accurately check a card.

The difference between 2048M and 4096M is 1 bit. Its the difference between a signed and unsigned number being used to track the file size, so it sounds like a bug in the software.

The 32G limitation is similar, but often a hardware limit. Its 32bits times the 8K sector size. Anyone actually used space past this point? And yes, this is where counterfeit cards come into play.

I wouldn’t “full” format. This just zeros every sector. Not only is this not required and a waste, but that since its flash memory, that will actually do the opposite of what you want and could slow down your flash.

Interesting that exfat works since these embedded devices don’t run Windows. Exfat is a modification of the ntfs filesystem. Its still proprietary and Microsoft has only had the specs published for about a year (although the Linux guys reverse engineered it years ago and I’d bet my lunch the camera runs Linux).

Well it turns out that exFAT does not seem to fix the 2GB limit for recording timelapse. I tried reformatting the SD cards using exFAT for two of my Wyzecams and set them for extended timelapse recording. Both stopped recording at file size 2048MB.

Since I never heard back from Wyze tech support, I am giving up on trying to make this work. It’s a bit annoying, but I just need to stop and restart my timelapse every 1.5 days or so (recording HD at 6 second intervals).
Thanks to all for trying to help me out.

1 Like