Time on iOS notifications is wrong

Deleting the app and resintalling it from google play fixed this issue for me. Thank you for everyone who posted this.

Did not work for me either. Deleted a couple of cameras and reinstalled without cure. Nothing works. Using iPhone with everything updated. Someone, PLEASE, find a cure and post here.

The cure is for Wyze to fix their code. They don’t care.

I am still experiencing this issue. I’ve tried everything (see above) and ultimately turned off notifications altogether for Wyze.
I submitted a log file to their support and tried to discuss it with their support team.
I encourage anyone still seeing this to take a screenshot and “Submit a Log” under Wyze Support in the Account Settings in the mobile app.
That’s the only way they’re going to fix this.

I was provided this templated response:
"Thanks for sending the log! Our engineering team received your log and is now aware of this concern. Your log, together with the troubleshooting steps that you tried will be greatly helpful for the ongoing investigation. I may not be able to give you a timeframe for now as to when the update will be released because we are still working on it. Once we deploy the patch fix for this issue, you will receive notifications in your app that will encourage you to update it. We appreciate your patience during this time.

We will take this experience as a tool to continue improving the level of service we are giving to you and to the rest of our customers. We are actively working to cater to these experiences for the betterment of the products and the app."

Seems to be the same issue as posted on this other thread. I’m seeing the same issue after international travel and submitted the logs to Wyze and Support.

Yet another thread on this, it appears…

If many people are bothered by this issue, perhaps we should vote on this for the next Fix-it Friday.

Honestly I am getting notifications at the right time, so it doesn’t bother me that the timestamp on the notification itself is off. Other apps don’t even show a timestamp on notifications and I never really felt the need for it.

I would happily vote on this for Fix-It Friday.
Didn’t know that was a thing (I’m new here).
Please advise how to.

Here’s the post from this past month:

I’ll add an entry when the August fix-it Friday comes out. :+1:

1 Like

Please post a link here so we get notified!

I was actually able to fix my Android by clearing data, uninstalling, restarting, and reinstalling. My wife’s iPhone, for which I am obviously less familiar, we uninstalled and reinstalled and it’s still displaying wrong. Not apparent where to wipe data/cache on iOS.

Thank you.

You can clear app cache by going under Account > App Settings > Clear.

Didn’t do any good for me though. Didn’t try uninstalling/installing the app. Especially with the new app version out, I’m not sure about updating to it just yet.

Is there a system cache to clear in iOS? On Android you have the app’s internal cache and then a system cache for the app; you can clear the apps internal cache and then see the remaining cache in the system settings.

edit: missed a question mark.

It seems deleting and reinstalling the app is the best you can do on iOS.

Other than Wyze app cache, you can delete browser cache, which shouldn’t matter in this case.

Just noticed the same issue on android after trip to Asia and back.
Come one Wyze it’s been 4 years now, still not fixed?
Tried some of those sync device, see if it helps.
If not, going to try the clear app data/cache.

Going back to older posts on this thread, the original issue seemed to happen due to daylight savings as well, and the workaround was to reinstall the app. That doesn’t seem to fix the issue for most of us, at least not on iOS.

I noticed this issue since the end of June. I assume the bug cropped up a little before then, or we should have seen more posts on this.

App reinstall doesn’t fix the issue consistently on Android either. The bug still exists for both OS.

I just set up one Wyze V3 and the time notification is three hours behind. I never traveled out of the time zone. I uninstalled and reinstalled the App on IOS, cleared the cache, turned off and reconnected both camera and iPhone with no resolve, Also I sporadically get notifications, if I get one and there is motion after I won’t get another. I probably will return this if I can’t solve this in the next day. Frustrating!

If you never traveled to another time zone, perhaps you can try what this article says. It didn’t help me but it might help you.

Tha August Fix-it Friday is up. Please like my post under that thread if you want to vote for this notification time issue to be fixed.

2 Likes

I’ve started seeing this issue since traveling to Europe and back to the US. My iOS notifications have a time that is now 6 hours ahead. My family also see the same problem on their phonies. As a previous iOS developer I can tell you that the messages in those notifications come from Wyze server side. The app itself has nothing to do with the notification until you tap on it. Some how the Wyze app had previously realized I was in a different time zone and told Wyze. All notifications since have been stuck in that time zone. What I don’t understand is why it didn’t do the reverse when I returned to the US. Frustrating !

2 Likes