These connection issues are getting ridiculous

I find it interesting that there are no moderator comments in this thread. Kinda shows that this is one of those issues that Wyze just doesn’t care about, since poor testing didn’t catch it. I quit updating my V3 firmware and the app long ago because of these exact types of issues. For me it all started, with the jumpy video I reported last year, which still seems to be an issue for those with sound turned off. I downgraded my firmware then, stopped updating the app, and everything has worked great ever since.

How do you downgrade the iOS app

Also there does not seem to be anyway to contact the support team online. All you get are nonsense replies.

Bernard Kaufman

Look for the post by “bryonhu” earlier in this thread. He has a link in his post to rollback on ios.

Do you believe that the moderators are Wyze employees or are somehow directly associated with Wyze?

The Mods are not Wyze employees…they are volunteers and customers just like the rest of us. Wyze personnel do sometimes chime in, especially if requested by the Mods.

No they are not employed by Wyze, but they always “push” the Wyze viewpoint. Yes things often happen with Wyzes releases, because of poor testing, but normally they step in and ask questions to get more info and later note if it’s an issue or how to work around. This time it’s total silence.

To roll back the App on iOS devices you need to join the beta group and install test flight. Once that’s done, you can roll back to earlier versions.

I don’t know about ios. I was just responding to a question someone asked me about rolling back. Someone else posted a link on how to do it on ios.

Just FYI, as was posted by “byronhu” in this thread, you don’t have to join the Beta program to rollback on Android. There are other options, though I have no idea how safe they are.

Didn’t mention Android as I don’t have one. For iOS, beta is the only way to get older versions. I have Test Flight installed on my iPad and iPhone and frequently roll back to earlier versions of the App when Wyze breaks things.

Happy to defer to your experience, since I’m not on the same platform. :+1:

I’ve recently had similar issues of combination of above responses. From some time now been trying to figure out a connection issue with only one of my Pan Cams and thought maybe it had been compromised with so many issues of hacking out there. So I ended up switching it out with one meant for my Dad just seating there on shelf because he declined since he had something else. Worked for a short while without issue until now but recently ended up effecting most of my regular Cams coming up with error code 27. So I started process of elimination first checking the other different brand Cams to see if connection issue on my end (router/internet) and was working. Which lead to my original thought maybe was Wyze servers through AWS the issue. So ended up looking through all my Cams and found that the OG and DoorBell still worked but if was servers then none of the Cams should’ve been working. Also checked my Events and found that they were still being recorded/uploaded. Checked my old Galaxy S7 phone and found NO issue live streaming. Then checked App update on both Galaxy S7 and my newest S21 to only find both had same update. Lastly ended up uninstalling and then reinstalling App on my Galaxy S21 to finally once again have live streaming again. Not sure what all this means, however as always best approach to start slow and simple then work up cause I really didn’t want to have to roll back all my Cams to a previous version. Also on another note as with anything in life best practice to have a backup because to rely on just one life line that ends up getting cut for any multiple possible reason is not a good place to be. Sorry to say Wyze, however still really appreciate all that you have done and looking forward to what you will do in the future but of course with my eyes open. Hopefully this helps some if at least one of you out there. Happy NEW Year 2024 !!!

I read this a few days ago but was too busy to pipe in.
I have iphone/ipad running beta app 2.48.0(4), and 10 V3 cameras running beta 4.36.11.7095. These cameras are all outside, and I have a 4 node TP-LINK mesh system, interconnected with Ethernet cable. The issues you describe having are not happening here. They are similar to problems I was having with most cameras up until say juneish 2023. then for unclear reasons things got stabler which I assumed maybe was due to wyze beta app/firmware.

There are a couple of things I do which may help you.
a) If I power tap to different levels in the app quickly then configuration or displayed info is stale/wrong/default. This is most noticeable when trying to change a detection zone as the changes fail to save or get blanked out. As a Type A personality i tap fast but force myself to go slower. Remember the app isn’t just talking to the cameras, it is also getting data/updating from very remote cloud servers.

b) add Shortcuts and scheduled restarts. Shortcuts can be manually triggered at any time when the app is open. Schedules trigger on a time or event. results of each can be seen under Account → Rules → History

To configure Shortcuts and Schedules:
In the app, goto Account → Rules.
i) Create a shortcut which reboots all your cameras.

ii) Create a shortcut which uploads a video to the cloud for all cameras.

iii) Create two schedules to restart all cameras, one that runs at sunset and the other at sunrise.

iv) on each camera go into Settings → Device Info → Firmware Version. Disable ‘Update automatically”.

I strongly believe this greatly increases the length of time of sanity/functionality of the cameras.

Note the beta apps show more info while connecting to a camera. they display three stages before live feed starts.

  1. starting secure connection
  2. authenticating with camera
  3. loading video feed

This is much better as you can see progress toward success, or where it can get hung up. Also the speed at which it traverses the three stages is a good indicator of health.

I have one camera at the edge of my property that insists on connecting to a remote TP-Link node that has a weak signal. I can groom it back onto a better one but it is dodgy on a weak wifi:
a) times out on live feed
b) fails to update events to the cloud
c) disconnects when adjusting settings like detection zone
d) fails to accept setting changes
When I force it back onto a closer router those problems disappear.

The app needs to connect to cloud servers quickly or it times out, and also to the cameras. You cannot really declare your wifi network is fine because it is working great on your laptop, your cameras will demure.

Minor ongoing problems I have:
a) around every 3-4 weeks one of the cameras at random will indicate it is OFFLINE in the group view, but when I ignore that and try to goto LIVE view it either works (state mismatch) or is truly offline (state correct). The only way I can get this state mismatch to stop is to power cycle that camera.

b) also around every 3-4 weeks when i tell a camera that appears to be functional to restart with the app it just pretends to restart but doesn’t actually restart. I can tell it fails as the live view which should stop for 30-40 seconds, doesn’t stop. IMHO this camera is dancing on the edge so to speak, This state also requires a power cycle of the camera to recover.

Perhaps your cameras are also in some weird state which may have more symptoms then I am seeing.

Ah yes, one specific camera I had removed the cover over its USB cable to thread it through a hole but did not replace it properly. The connector has corroded and I have to periodically spray contact cleaner and scrape crud out to make it stable. So make sure your connectors are clean inside and are properly inserted.

That’s all i got.

Thanks robughblah for all the great info, plus yours was nicely laid out then my blob post, thanks. Likewise just as business as others, however for some on this post should be aware of and appreciate what Wyze is doing which is build a community in lieu of expenses products. The purpose of a community is to help each other out and there is a lot of info here to do just that. Now there’s always going to be exceptions such as my Pan Cam v3 is bricked despite all I’ve tried. Yes I could’ve sent it back for replacement but I wanted to try to make it work and if nothing became of it then I’d only have lost $35 in my endeavor. Unlike many other brands whose starting price are no less then $100 for ONE Cam plus subscription cost equal to that of Wyze were you can have multiple Cams. Prime example Nest Door Bell and guess what still has some undesirable issues such as lag between ringing the bell and video but hey it serves its purpose. However if I was heavily invested is these other Cams $100 each not matter what the brand they’d better work regardless without my involvement because I would expect them to function for those kind of costs.

Quick of topic but relevant, there are companies out there that are trying an approach we all should be apprehensive about such as Peloton were you spend a good deal of money but can only use if have a subscription otherwise its bricked. This to me is insane that if I have an expense piece of equipment I’m unable to use just even the basic functions. Seem to be the way HP Printers was heading that if you subscribed you have to use their service then on or else it’ll be bricked. As for HP Printer, I didn’t find out until afterwards because I was researching certain functions that I required but I’m ok with the extra functionality and services for the small cost of subscribing. Unfortunately, I’d be unable to sell it if I decided to upgrade unless the other person was willing to take up the subscription because it’ll be bricked.

I second TomG’s suggestion. I was also one of you people who was always complaining and blaming Wyze for everything. I have two properties that I monitor with v3 cameras. Two different networks 600Km away. After getting rid off ISP supplied modem/router combo and an old (more than five years old) router and switching to modern W-Fi 6 Mesh routers, all my issues have vanished. Haven’t had any connection issues (except known AWS blackouts).

Configure your networks people and get modern hardware.

I’m glad you resolved your specific issues. But keep in mind that your situation is not the same as everyone else’s. There’s a big difference between your situation, where you’ve been having issues for a while, and the numerous people that reported they had no issues what so ever, until they upgraded to the most recent app version 2.48.x., and now they can’t connect.

Wyze has a long history of breaking things with their firmware and software releases. So your solution might have nothing to do with their issues.

Likewise, if their setup worked fine before and now suddenly doesn’t, telling them they have to upgrade their Wi-Fi hardware might not solve their problem.

1 Like

Just curious… How big is the location where you put in the mesh routers? How far apart are the cameras?

Thank you!

The home is 1800 sq.ft. three floors split level. The furthest camera from the router is about 36 ft going through a one drywall and one concrete wall through the garage. The cottage is much smaller, one level. The furthest camera is about 30 ft from the router going through two drywall walls and vinyl siding. At both locations I only have just routers, no additional nodes, I’m cheap that way :wink:

I do not have these error codes “connection failed” with V3 placed on home lan.
Occasionally have error code -15 on V3 that is placed in remote location few miles away but error usually goes away after a day or two when I give up and leave camera as is.
-15 error is not even documented on support pages, so many error numbers are probably because they put bunch of printfs in the firmware code, so they know more exactly where connection fails.
When error happens and i go there to check camera, I noticed live stream (viewed locally) freezes frequently and recording to sd card has many short gaps.
I do no think these errors always indicate bugs in firmware.
There could be wifi connectivity issue and camera is trying reconnect frequently or ISP might implent some stupid security (so you do not stream another purge episode for example) or perhpas lousy qos scheme, or perhaps upload speed is not stable. To view live stream 24x7 definitely you need stable upload speed.

Every single time we lose power, all of my Wyze cams (with the exception of my lone v3) will stop talking to the network and app. I have to literally delete them completely from my app, re-add them again as if they are new cameras, go into my account online, and add them back into my plan. It’s ridiculous, and this fact alone will keep me from buying any more Wyze products going forward. They’re wonky, they aren’t supported, and they don’t work correctly after about 24 months of usage.

I am so sick of the cameras (Cam pan v3) that I’m ready to chuck the whole lot. I’ve got great WiFi with Verizon FiOS and a router with an extender (recently installed for the cams in the front yard) and their connectivity is very bad. I don’t think it’s the WiFi, because one minute it’s all good, and the next minute every camera won’t connect. Even older cameras (out of the 9 I have) won’t connect. Even those literally within 5 feet of the WiFi router. Meanwhile, I have TV sets on WiFi on the other side of concrete walls that don’t skip a beat.
The problem is with the Wyze servers. I believe they cut their capacity too close. Or just poor providers.
Anyway, I’m researching better products and almost at the bail out point with Wyze. And I don’t think telling us the company is operating in the red makes it look like Wyze is into or capable of solving the customer’s issues.