Thermostat latest firmware (1.2) issue

yes. So far so good for me.

Bad news, this update did not fix my old thermostats, and caused the same issue with my replacement thermostats that were on 1.8 and working perfectly fine. I did not want to install the update on my replacement thermostats, but they forced this update. You couldn’t use the thermostat at all without updating to 1.2.1. Never again will I buy another Wyze product. Wyze needs to refund everyone who has purchased a Wyze thermostat that doesn’t stay connected.

Why would I need refunded on something that works?

1 Like

The one unit (of two) that we were having problems with stopped having connection issues around April 1 so I was not happy when the recent update was forced on the units. However, I haven’t had any issues so far. Both units are working well in separate locations.

1 Like

I edited my post to say ones that they broke with firmware updates. I thought that was implied.Yeah, if you have one of the lucky ones that doesn’t seem affected, great. After spending many hundreds of dollars on Wyze sense which they know have a hardware flaw if you don’t replace the batteries fast enough or soon enough, and now the thermostats failing, I definitely can’t recommend wyze anymore, and certainly won’t give them any more of my money.

Hey Earl, did they change the tip screen with this last update and remove the tip wording? They haven’t delivered my Room Sensor yet so I’m not sure if I need one installed to see that, but it’s not in mine:

Also, like you I have been very happy with the functioning of my T-stat controlling my Gas\Heat Pump Package unit since install. I had an issue on install, but that was because my GPS was off. Since then, it has performed flawlessly even after this last forced update.

Unfortunately the 1.2.1 update didn’t help mine. I cycled the power and it came on like it always does. Within 2 hours it was back offline again. All the cameras still work perfect but again Thermostat offline again. I just wish someone could explain to me why the Thermostat keeps going offline but the cameras work perfect.

I can’t really give you any good advice on how to troubleshoot or fix your offline issue. My only suggestion would be to get this on the FIx-It Friday Topic thread where it will get some Wyze visibility. I would also encourage anyone else having the issue to also post detailed problem descriptions and vote (like) for issues they would like to see fixed.

Curious on everyone’s Thermostat that is working and not having the offline issue.
Are you using the C-Adapter with your thermostat?

I am not having the offline issue any longer and am not using the c adapter

Back offline again :roll_eyes::roll_eyes:

I do not use the C-Adapter. Still having the issue with my old thermostats, and now with my warranty replacements after the forced upgrade. I run all ubiquiti network hardware and have no issues with any other devices including 20 wyze cameras. The replacement thermostats on 1.8 worked flawlessly for the two months from when I got them until the forced update where they then both went offline within 24 hours of the “upgrade”.

since firmware update keep getting notification saying “it seems the cool stage wasn’t keeping up, your thermostat has restarted the system” This at our Florida home 1400 miles away. Anyone have a similar experience and/or solution?

I wish I had come to this forum first. 2 months thermostat cannot go more than a day without going offline. wyze came in same location rock solid. its not the wifi, its not the internet connection . its the thermostat.

1 Like

Firmware 1.2 and later broke many thermostats. Wyze won’t acnowledge the problem, and even forced me to upgrade my warranty replacements by requiring firmware 1.8 which was rock solid be “upgrade” to 1.2.1 which brought the issue back within 12 hours.

Hello to all my fellow Wyze product users and apparent “Tech-Migraine” sufferers, Although Ive been registered on this forum for some time now this is my first ever post after many hours of reading others issues. I realized fairly early on that many users here are likely better prob solvers than Wyze’s internal support staff or FAQ pages etc. That being said I’m the type to look here first for fixes to many product issues and broken features etc. I usually allow every one else to complain to support first as I have a deep rooted dislike of calling ANY tech support from ANY company as I always feel like I know more than them about the issues and getting Resolve or Satisfaction through direct calls seldom ever happens with any company anywhere. So all that BS aside I have had the same issues with firmware updates for almost Every WZ product I own . Also it seems that the APP side development teams do not play well with the various Product Dev Teams in that whenever one is updated and the other is not , Almost always another “Bug” arises in a device that either used to work great. I have the same update issue with my thermostat always going off-line and re-setting furnace breaker is the only fix. Now that were out of winter I’m not too concerned (until fall) and I would expect to see a fix later on. However I reported a bug to Wyze in Jan 22 about the “Filter Management” section of the app not working AT ALL. Whats the purpose of telling the app my filter sizes- locations and filter life cycles and it always says 0% used (even after 5months of operation and several hundred hours of runtime. I expected that the t stat update would maybe fix this issue as this was main reason I purchased and installed to begin with but instead we get more headaches than improvements. Don’t get me wrong , I know this company is only 4 years old and still have some work to do. I absolutely love the V3 starlight cams and have a triple V3 and single V2 pan mounted to a customized flagpole setup for 360* view night Astronomy and time lapse recording etc. OK I see I’m rambling on here but anyhow , Anyone else having the same Filter Issues ?? Any firmware version ever have this feature working or just me ?? On the same note with Wyze Switch I bought a 3 pack on first release and have one installed that put plain and simple is worthless I can’t even get it to stay online for an hour without resetting switches circuit breaker constantly since its 1st and only Firmware Update released. Again I’m hoping Im not alone on this issue as There apps troubleshooting section is more akin to getting a root canal than a pleasant experience .
Bottom line here is this company should focus more on keeping these comparatively inexpensive products working “Fully and Reliably” both App side and Device side before developing more gadgets to introduce and “Future Migraines” I’ll post later on some other products that I have found bugs in and as of yet have not shared with wyze or this forum.
Thanks for reading this if you made it this far… TMeister out. : )

1 Like

I’m having the same problem did the update an now it keeps going offline every 2 or 3 days

Mine is doing the same thing

Here is a work around, works 100% on mine

Workaround for the Thermostat constantly going offline.

For over a year now I have been fighting the problem of the Thermostat going offline!
The only way I could get it back online was to physically power cycle the thermostat, but that was not always handy as most of the time I am approximately 120 miles away.

I installed a Shelly 1 WiFi Relay switch (the downloaded Shelly app is on my Android phone, not sure if it works with iPhones)

I installed this relay at the furnace

Supply 120vac or 220 (see Shelly instructions) to the “L” line and “N” neutral connectors.

Splice and insert wire going to the “Rc” terminal of the thermostat to the “O” on the relay. So the wire coming from the furnace to the thermostat will now be connected to the “O” relay terminal. The other side of the “Rc” wire that is going out to your thermostat will now connect to the “I” terminal of the relay.

Then set up the app on your Android phone.

My thermostat has gone offline 3-4 times this month. Every time I cycle the Shelly relay contact the thermostat comes back online. So far this has worked 100% of the time.

This relay is $16 on Amazon

SHELLY 1 One Relay Switch Wireless WiFi Home Automation iOS Android Application…

Buy SHELLY 1 One Relay Switch Wireless WiFi Home Automation iOS Android Application - 1 Pack Non UL (1, Count): Routers - ✓ FREE DELIVERY possible on eligible purchases



an update on my situation, I had gone through all the troubleshooting steps that were provided by wyze support, provided feedback, and without quesiton they sent me a replacement thermostat. It was replaced, 3 months later not a single drop.