"Take Photo" behaviour is erratic

I used to be able to pause a video playing from the camera SD card, press the “Take Photo” button, and the app would save a photo taken at the point at which the video was paused. Recently, I noticed that the photos were no longer being saved at the time at which the video was paused but anywhere from 4 to 14 seconds later. This rendered the feature somewhat useless.

I have four v2 cameras and the app installed on three different Android devices. The problem was seen on all devices and all cameras, so I submitted a support ticket and was referred to the beta program when the issue could not be solved.

The latest beta version of the Android app behaves better but there is still a delay of less than one second between the time a video is paused and them time at which the photo is taken. I note that the beta firmware does the same thing as the latest production firmware.

I would love this to be fixed.


If the delay is less than 1 second now I am not sure if there is anything to be fixed? Is the delay consistent or does it vary? And when you say a delay what two times are you comparing? Not being snarky trying to understand.

I was told that “some” other people have reported this same issue, so not being snarky but did you try it on your own device before you posted?

If the subject in the video is moving then it can easily be off frame by the time the photo is taken. I think most people would expect the app to capture the frame at which the video is paused rather than some other random frame. That is certainly how the Wyze app used to behave.

I just fired up a video in VLC media player, paused, selected “Take snapshot”, and the frame it saved is the exact same frame at which the video was paused. The concept and the expectation is quite simple.

Yes I tried it before posting and like you I don’t see any difference hence no problem. It jumps to the event within or less than 1 second of difference in time.

I would definitely consider this to be an issue if the time difference was larger. One thing I have noticed is that the time on these cameras drifts over time. I have 9 cameras and over a week the time on each camera will differ by as much as 3 seconds.

It seems you have misunderstood the issue. Here are the steps to reproduce it on my v2 camera:

  1. Choose a camera from the Wyze app.
  2. Press “View Playback” to view events that are stored on the SD card.
  3. Find an event that shows some object moving through the video frame.
  4. Pause the playback while the object is moving through the video frame.
  5. Note the position of the object and then press “take photo”.
  6. Go to the Album and view the photo just saved.
  7. Compare the position of the object in the saved photo to the position of the object in the video player when you pressed “take photo”.

On my devices, the video frame saved in the photo is not the same video frame that was displayed when the “take photo” button was pressed. “Take photo” used to capture the frame at which the video was paused but it doesn’t any more. My expectation is that it should still do so.

1 Like

Interesting, yes I did misunderstand you, my bad. I will have to do some experimentation myself and see if something similar happens. Luckily I have lots of footage of people and dogs walking through the back yard of the condos.

1 Like

Ok I noticed the following in my experiments. If I paused the event video and then took a picture the time was for all practical purposes identical.

If I took the picture while the clip was playing then the time would vary as much as 2 seconds.

It appears the frame rate can vary significantly in the event videos depending on a number of factors including what you are viewing it on. For example my Android tablet had the worst performance and I would often get pictures that were at least a second off time wise.

My iPhone and iPad were much more responsive and my pictures were usually dead on accurate as far as times went.

So this issue appears to have more to do with the equipment and environment than anything Wyze is doing. But I honestly don’t know for sure.


Thanks for your tests. I can’t comment on any Apple devices but the behaviour that I’ve seen is consistent on all three of my Android devices that run either Android v7 or v8 and that were high end devices in their day
and that can probably still be considered mid to high end devices, now.

In the beta version of the app, my experience is that if you pause the video and take a photo, the timestamp is generally the same but the video frame that’s saved is somewhat later. For moving objects that can mean that the photo is nothing like what you wanted to capture. This depends entirely on the situation.

In the production version of the app, if you pause the video and take a photo, the timestamp is always at least 4 seconds later, which usually makes it useless and that’s why I raised this issue in the first place. This brings me back to what I said earlier, i.e. the app should create a photo using the same video frame at which it is paused. That is what other video players do and that is what the Wyze app used to do, before the new libraries were implemented, i.e. mid-2019.

That does seem to be undesirable behavior but I can’t replicate it on Apple iPads or iPhones. My Android tablet is pretty slow and runs Android 6 so it is actually worse than what you are getting.

That said this appears to be specific to Android. I know there was a lot of discussion about the hardware accelerator being removed about 2 months ago. I wonder if the two are related?