Strange WyzePlug/Alexa communication

There are two Amazon Echos in my house, one in the kitchen and one in the master bedroom. I have a number of WyzePlugs that almost all are accessible by either Echo. The one plug can be accessed by the kitchen Echo, but not by the bedroom Echo - and it’s in the bedroom! Not long ago I had to delete that Plug and re-install it, but afterward it was accessible by either Echos. Within the past week, The bedroom Echo says “I’m not connected to the Internet, please reset and try again.” when we try to get it to access by Plug. Any other Plug, light switch (smart switch, or smart socket), and the Echo does what it is asked. I’m stuck. Will deleting the Plug and installing it again resolve this?

Thanks in advance.

A couple of things to look at. In order for a certain echo to only control a device, you need to make sure you add it as part of the Room or Group. Then in that group you indicate which Dot or Echo will control the group.

For Example: I have 2 lights in my family room and 2 lights in my living room. My Family Room Dot will control my Family room lights and my Living Room dot will control my living room lights. So no matter which room I am in, I can say turn on the lights and only those lights will come on. But I can still say turn on the Family Room Lights when I am in the Living Room and the Family Room Lights will come on.

However, you could disable the Wyze Skill and then Enable it again. Deleting the device from Alexa and then doing a discovery may correct it as well. Curious at what command are you asking when it indicates the “I’m nit connected to the internet” statement?

1 Like

You might also consider rebooting the Echo device. It could be having some issues as well.


Its likely just me, but I could not clearly get a picture in my head, that the Wyze plug was not being used to start the Echo. If so, then the Echo is not turned on/booting until the plug is on. Probably just me.

1 Like

I was a bit confused as well. That is why I was also asking for what command they were asking Alexa to do.

The plug controls a fan in the bedroom. In the evening, when the outside temp is below inside, we have the fan on blowing outside air in. The command, simply, is “Alexa turn on the bedroom fan.” As I said, until just the last week, the plug did exactly what it was supposed to do for quite some time. However, about three months ago, I had to delete the plug and re-install it, but it was as a result of a power outage while the plug was on. All the other Wyze Plugs in the house were off when it happened, so I just figured that one was caused by the outage. And, to make it as plain as I can, previous to the outage, the plug had worked correctly for quite a while.

All the plugs in the house have names that are unique, so either Echo can control them: i.e. den fan, bedroom fan, surround (to turn on the amplifier and wireless connection for my surround system when surround is available), tank light (for the light in my aquarium), etc. There are others. Plus the smart switches have unique names, and are also controlled by the Echo. And… two garage door openers - neither Wyze, because I set them up before the Wyze was available. Also unique names for them, Altogether 16 smart units controlled by the two Echos, or on schedules (and controlled by Echo when needed.) Until now the only problem I had was having the firmware updates trash 5 of the plugs before I convinced the tech support folks it was an issue!

Hopefully, that explains that.

Looks like you’re of the opinion the best answer is to delete and re-install. I’ve already rebooted the plug (more than once), and rebooted the Echo more than once as well. Not much left. Just thought I’d see if someone had the same problem or something similar with a unique answer.

Thanks for taking the extra time to help us understand more. And how this came to be.
Please forgive me - telling you something you have already tried and tried over and over.
We often don’t see what you see, and we have to think - clean slate when trying to help.

You need not answer these, but only meant to give you some tips of what to look at.

  1. Are you running this plug from a routine, or just saying all that each time to turn it on?
    I ask because if its a routine, when you removed and added it back, Alexa does not recognize it yet, because its “logical unit ID” changed between deleting/losing it and adding it back in Wyze. If you are running it from a Routine, delete it inside that routine and then add it back.
    After adding it back, check and see if it works. If it does not work, continue with 2-5
  2. When you added back that plug, did you use the same name it was? Did Wyze offer that name as the name it was when you originally named it?
  3. When you look under Devices in the Alexa app, do you see it with that name it was? If same name, when you check its properties does it show “not responding” at the top?
  4. I would find it in Alexa > Devices > properties and delete it. Then close the Alexa app. Use one, (probably the one in that room) and Discover Devices. Many times, a discovery will report no new devices found, BUT, when you go into the app, (open it now), and look under Devices, you might find it near the top of the list, with a green dot. That shows us Alexa has found it again.
  5. Personally, I would delete it from Alexa > Devices, go into the Wyze app and rename it, (even better, delete it and add it back) With a different name and having been removed from Alexa, its going to treat it as a new never before used device. After the rename, or added back, Discover Devices. Once done, go look in Alexa > Devices. Should be there with the green dot.
    Disabling and re-Enabling should not be necessary during any of this.
    And I will now be reallllly surprised if its not back.