Setting up a Wyze base station, using Various LTE devices

Having access to the existing modem/router at that particular location isn’t an option.

Of course… the devices below were set to Hotspot, using an active data SIM card

I was hoping one of the following methods works:

  1. a hub, having an RJ45 jack was plugged into an LTE tablet
  2. the LTE notebook included a built-in RJ45 jack
  3. another notebook, (w/o RJ45 jack), using a USB-A to ethernet dongle
  4. tried MiFi 7000/8000 (LTE), hotspoted to a device that has an ethernet jack
  5. tried my cellphone, using a USB-C to ethernet dongle

I followed everything correctly as I always do when setting up a conventional router with Wyse base. No matter what I tried, I couldn’t get the Wyze base station to connect/sync.

Unfortunately that wasn’t the device I was expecting to use… It finally worked when I tried this expensive route, using a Huawei E5885 Mobile 4G LTE FDD/TD 300Mbps, since it include its own built-in ethernet jack.

I just don’t understand what’s the technological reason why none of the other methods worked - any insight?

Did anyone of you folks tried this type of set-up and succeed?