SD/HD Switch on screen rotation iPhone


I am using beta firmware on my V1 cameras, have noticed a funny little glitch/bug. (Am NOT sure it wasn’t also present on prior firmware)

When selecting a camera from the first page of the app, it opens the live view screen, I see the small green HD icon box left upper…

If i rotate my iPhone 7Plus 90 degrees to get a bigger picture (HUGE improvement by the way, now ADD it to the iPad version); and view the screen/image and then rotate back it now says SD in the left upper.

I was puzzled, tried it 10 times and can verify it happens on nearly all of my cameras.

IF I then click the NOW visible green SD box in an effort to switch BACK to HD the camera responds with the “please wait” text box and appears to take a couple seconds to switch back to HD mode.

NOT entirely sure if it is ACTUALLY doing anything or switching modes, in fact I thought I was hallucinating it at first, but it is real and reproducible at least for me.

Thanks, Patrick




what version of the ios application is being used on your ip7+; i.e. ga/pub release, beta, etc.

Beta firmware as above, so iOS app is 1.2.86

thanks patrick,

are you able to load ga/pub release ios app on another phone/tablet, and try to reproduce the issue.

if the issue persists, it might be firmware related.

if the issue does not persist, it might be application related.

thank you!

hi patrick,

if possible, and as an alternative, you may to consider downgrading the v1 firmware and seeing if the issue persists.

there is a v1 firmware downgrade thread in the beta forum.

thank you!

I tried the same experiment on an older iPad (Maybe ipad4; 9.7 inch as i recall) it is running the general release iOS app, and is on iOS 10.3.3
The wyzecam app on that device is 1.2.84

i do NOT see the same behavior on the iPad.

Interestingly even though i had seen the behavior on ALL eight of my cameras earlier today, AFTER having opened, tested, viewed and switched manually from SD back to HD (after the screen/app/camera reported going from HD to SD as above), NOW the issue seems to have resolved itself?
Or possible restarting the app or the phone may have improved the issue? Not sure

Maybe the action or process of going thru this exercise on each camera has updated something?

I have no idea, but i DID certainly see it, have video and screen caps of it happening as described above.

My cameras are working well (despite the glitch as noted) they are staying connected and video recording and still shots are excellent.
I have no need or desire to downgrade to the prior firmware, on the contrary I LIKE the newer firmware, this is just something that i observed and wanted to report is all.

Thanks, Patrick

nice, thank you for the update patrick!

Hi, thanks for reporting the issue. Yes it is a bug in our code. We fixed it in V1.3 release (not released yet). Thanks!