Rules not working as they should

I have very simple rule:

Between hours of 8pm and 7am, when Door is Open turn on Light and when Door is Closed turn off light.

During these hours, between 8pm and 7am they work no issues. After 7am, my lights are staying on, regardless if I am Opening/Closing Door.

Am i missing something or this should not be happening.

Everything Wyze is up to date.

Do I need to create another rule or?

Yeah, try adding a fallback rule, like turning off the light the rest of the time. Seems that should have been in there by default.

I see, so I am missing rule between 7am and 8pm telling Sensor when Doors are Open/Close to turn off bulb?

So I need two more rules?? turn off lights when door is open and turn off lights when door is closed. I thought this update would make this functional, its seems so off that you need to create additional rules so lights is on/off between select hours.

Or actually i need Schedule Rule, where i say to each bulb to be off?

You shouldn’t have to add that fallback rule. I suggested it to confirm the bug, and if really a bug, to report it.

Are you saying that the light actively TURNS ON at 7am? Or is it simply REMAINING ON if it was already on at 6:59am?

If it’s simply remaining on when it was already on, that’s the expected behavior based on the logic you’ve written. You’ve never told the light to explicitly turn off, which means that starting at 7:00am, it will simply retain its most recent state until it’s told to do otherwise.

No. Just one rule to turn off the light at 7:01am. That’s all. If it’s already on based on the earlier door rule, it will turn off.

If you’re saying that the light is SPONTANEOUSLY turning on at 7:00am when it was already off, that would be unusual and it sounds like a bug, unless it’s coming from another rule. But regardless, I would think that if you tell the light to turn off at 7:01, that would still address the problem.


Hey @nerdland , thanks for responding.

You are right, they are remaining on. I am creating rule for every single light bulb so lets see if it is going to work.

Cool. If they’re just remaining on, that’s exactly what the rule you created is telling it to do. Computers are only as smart as the instructions we give them. :slight_smile: Since you never told the bulb to turn off, it just remains in its current state, That’s why you’d want to actively turn it off at 7:01. After that, it will remain off until you manually turn it on again. Then, starting at 8pm, it will either be on or off, based on your rule logic.

By the way, if you’re doing this with multiple bulbs, you may save time by putting them into a group so that you don’t have to make a separate rule for each bulb.

1 Like