RTSP for V3

This web interface (as opposed to configuring everything via SSH).

Yes, the web interface is part of the hack. You just need to enable it in the config file.

Entry in wz_mini.conf to enable the web server:
####WEB####
WEB_SERVER_ENABLED=“true”

2 Likes

Hey so, looking through the github notes for all the entries I see this:

RTSP streaming:

The RTSP server supports up to two video streams provided by the camera, 1080p/360p (1296p/480p for the DB3 [DoorBell3])

So, which is this DB3 that is supported with this firmware??? Cause I would like to get a cam on my side door, but no way to get power there or a network drop, and getting one of these DB cams there installed with RTSP would be ideal. Is it this one that is supported with this hack and adds RTSP?

No idea. I don’t have any of the doorbell cams.

Hey @WildBill , so got my dongle today and tried this hack on the V3 as I wanted to test it working with a POE drop, however, can’t get video via RTSP.
-I have the v3 RTSP beta firmware running on this camera, for reference (turned off the Wyze RTSP)
-booted fine with the 32GB mSD card, some voice prompts (loading bootloader or something like that)
-booted fine, I enabled the web interface so I don’t have to use ssh
-web gui showing the video
-Wyze app showing the video
-I can load up the stream in VLC BUT have audio, no video (black screen). When I check the codec info shows no video codec info, just Audio.
-Tried to load the camera in BI, getting a “Decoder not initialized” on the camera window.

Not sure what to make of it…

I’d suggest going to the github site for the hack and checking for solutions or asking for assistance there. Make sure you are connecting to the RTSP stream from the hack services and not the WYZE firmware. I think I saw some issues when using both.

You should check this portion of the web config:

1 Like

It is because you are running the old rtsp firmware. I had the exact same issue.

Upgrade to the latest normal firmware and it will work fine.

1 Like

That part is good, I do have everything enabled, so it’s a weird issue, may be related to the FW version as mentioned by @juched

Just a heads-up for everyone. Apparently the latest camera firmware updates break the wyze hack. The firmware has security updates that prevent loading from the SD card. Also, Wyze has removed the older firmware files due to the “security issue” so it is going to be difficult to go back if the cameras get updated.

1 Like

@WildBill I’ve been using the the old official RTSP beta firmware. (4.61.0.3 (v3) or 4,28,4,29 (v2)) with occasional testing of GitHub - mrlt8/docker-wyze-bridge: RTMP/RTSP/LL-HLS bridge for Wyze cams in a docker container with Home Assistant. I didn’t get around to testing GitHub - HclX/WyzeHacks: Hacks I discovered allowing Wyze camera owners to do customizations … I haven’t done an update since I installed the RTSP Beta. I expect my cameras to “die” with the current code. :wink:

Unless they do another forced push like they did at the beginning of the year.

1 Like

hmm… my RTSP Beta firmware cameras have never “asked” for an update (other cameras did get the update). I would not be a happy camper if I was forced to de-install that code,

I have 5 cameras taking a snapshot every day, every 15 minutes from 9:00AM to 4:00PM. I build an annual time-lapse movie that no one but me (I mean no one in my family or anyone else) is interested in. Why? Because I can. RTSP + ffmpeg is great for watching the grass grow and the leaves fall.

2 Likes

Oh okay, good, I guess RTSP users never got a push, which is also why they’ve buried the RTSP build. :frowning:

Correct. RTSP firmware does not get remote updates.

1 Like

Is there a place to download the last RTSP firmware for R3 and R2?

1 Like

Lucky I downloaded them!

In any case I’ve moved over to using the wyze mini hacks. The recent iCamera patch has made it capable of running fully offline.

1 Like

You wouldn’t happen to have that firmware available, would you?

Are you running a regular firmware then with the SD card mini hack that still allows you to view the wyze cam in the wyze app but if your internet is out then the RTSP stream via the hack is not affected?
How is the sound on the RTSP mini hack implementation? I"m running the wyze beta fw with RTSP and the audio is totally horrible, I’m ready to swith the wc3s out for the ezviz C1Cs that I was once using.

PM for the link

I started with the last good f/w revision. ATM I’m using the beta RTSP firmware and only using the hack for standalone operation with internet disabled for the camera. So RTSP via hacks is disabled and the RTSP URL is the one for the beta f/w. Was having some issues but so far so good.