Robot Vac will not connect

Hi @circ and welcome to the Community Forum! :slightly_smiling_face:

Wyze probably never received your message. After successfully opening a Service Request you’ll received an automated reply with the Support Ticket number.

You can try sending message from the web at:

-or- by phone:
Live support is available: +1-206.339.9646
Monday - Friday 5 am - 6 pm PT | Saturday 8 am - 4 pm PT

Update - I called support and was instructed to perform the factory reset - did it, and the setup went fine. Apparently my “failed” firmware update did actually take place as the vac came online with the current firmware.

I had deleted the vac from the app and when I set it up again it came back up with my map and virtual walls, but once I started a clean, the map disappeared and it started fresh. Re-mapping not that big of deal considering its working now.

One thing to note. When I did the factory reset, it took several tries to get the timing for the second home button press correct. First long press you will get the audio message “factory reset will begin”. You have to press and hold the home button again IMMEDIATELY after that message - maybe even during - and then you’ll get a different message that the reset happened. If you get “factory reset will begin” again then you haven’t done it right yet.

Good luck everyone.

1 Like

So you were able to connect before and it was working? Most of us can’t connect for the first time and so we can’t trigger the firmware update. Good to know that the reset fixed your issue though. Resetting hasn’t worked for me for my first setup so far…

yes, my vac set up and worked fine for several days before the updates and the problem.

I’m with you @shane.ppikelin . Never got it connected the first time. Tried Factory reset also but no luck.

recieved mine on the 22nd. i spent several hours trying to connect it for the first time to my android phone (latest app, also tried beta app) and i tried on my ipad. Neither was able to get it online. i tell the app my wifi password, connect to the wifi of the vacuum, i see it drops away. i go back to my wifi and it times out and the vac continues to blink blink blink. I have checked clients in my router and see a device from wyze i assume is the vacuum.

Got on the phone today, they should be sending a return label to replace soon. I asked about the micro usb option to update the vac and they said its not an option at this time…

(Wyze Robot Vacuum Setup Issue - 1/25/21)
1/25/21 10:00 AM PT - We are looking into an issue that is preventing Wyze Robot Vacuum setup for some customers. We apologize for the difficulty and will post updates here when we have them.



Ticket 1012357

I put in a support request and got a very similar reply along with directions on how to request a return/refund. I’m going to hold off a few days to see if there’s a resolution before I think about returning the vacuum. Fingers crossed!

Has anyone tried the app update pushed today via the Beta channel for IOS? States it fixed the issue with connecting.

And when will the android beta roll out for test with this fix?

just installed the beta on ios, but it didnt fix anything for me.

I did a reset on router, reset the phone, reset the app, reset the wi-fi on the robot. Factory reset the robot. I have tried them all. different combination.

Basically every time the App connects to the local 2.4ghz wifi with no issues, app prompts me to connect to the robot’s wifi. Mobile data off, I even forget the wifis I have in there to prevent the phone reverting back to my wifi. App connects to the robot’s wifi and immediately drops it. Then the robots wifi disappears and app gives a connection failed error. The app just asks me to repeat the steps again but the robots wifi is not even there so I have to reset the robots wifi again and again and again and nothing works.

Well hopefully by Friday we will have a solution on IOS and Android, or we will be receiving return labels and refunds. I seriously would like it to work properly I was really into its potential. Wyze wizards do some magic I know you can.

I have the same problem. It immediately drops from the vacuums wifi back to my own. I turned on ‘stay even though there’s no internet’ and disabled auto connect.

1 Like

I have the same problem. NO HELP from Wyze. Extremely disappointed. I have sent multiple request for help and I only get sent the same form email on the same crap to try that doesn’t work.

I have now initiated a SECOND return request…to which they reply with the same connection tips.

I want to send this thing back!!!

1 Like

Hi @markwalters and welcome to the Community Forum! :slightly_smiling_face:

Please try contacting Live support which is available at: +1-206.339.9646
Monday - Friday 5 am - 6 pm PT | Saturday 8 am - 4 pm PT

Update: They sent me a new vacuum. It paired just fine and works great. Great job Wyze!

PS Ive had the new one for a while now. The replacement was shipped just a couple days after my ticket went in.

Thanks for the update @christianolson292 :+1: Sounds like a Solution to me.
Curious if you had to return the bad vacuum.