Push Notifications Work, Don't Work, Work, Don't

Have you made sure the bell icon is not crossed out? Also make sure there is not a notification shortcut set up that is turning them off. What are your current settings set to?


Yes, the bell icon is incredibly hard to see on some devices (size and color combinations) and the slash/no slash even harder. Another possible issue is poor connection between the camera and the cloud server at any point.

Here’s a summary of where push notifications can be being blocked (assuming it’s not a connectivity issue):

  1. Per camera in the cameras Settings > Event Recording > Send Push Notification. This can be controlled by the camera owner or shared user and will affect both. This does affect Smoke/CO Alarm push notifications.

  2. Globally on an account basis by tapping the bell icon on the top right of the home screen, or using the switch in Account > Notifications. This affects only the owners or shared users login account on all devices they have logged in to the Wyze app.

  3. In the phone’s OS settings, which can enable or disable all notifications from any particular app. This applies to only that particular phone/tablet. (Note: this is not possible in some versions of Android.)

You can think of the three notification control options as three concentric rings or gates. If the inner gate (level-1, per camera) is closed, no notifications get beyond that level. If the gate is open, then the notification can attempt to get past the next level (level-2, account), etc.

As far as I can tell, I’m in compliance with everything which would allow notifications. I’ve done and undone all I can think of. It worked this morning and not one thing makes it work now. I cleared cache, cleared data, signed out, signed in, checked every button, toggled all on, off, on. Went to Android settings, all on.

Is this on my end?? It’s driving me berserk! I need the sound so I can check on my charge when he moves! And it’s all three cameras!

Cathie Simmons

I don’t use ifttt. Would it solve the issue?

I know this is the long route and the most annoying. But have you tried resetting the cameras to factory state and then redoing all the settings that you had. Might take a bit of time but might also fix the issue.

I’ve done it all. Nothing works. Deleted, uninstalled, did it all. I couldn’t be more flummoxed or disappointed.

Any further thoughts? I can’t fix it.

Could be a connectivity issue. Here’s the connectivity troubleshooting guide:


If that doesn’t solve it, keep in mind that this is primarily a user-to-user forum. If you don’t get help here from the community, file a support request including log files. That will ensure that the logs are captured. You might want to submit the ticket right away because there’s somewhat of a backlog. You can always let them know it’s already resolved when they contact you.

On Android:

How about a suggestion to make the notification High Priority like instant messaging apps?? I disabled battery optimization for Wyze and there’s still a delay of 5 minutes of getting the notification. The only way I could get the notification instantly is by disabling Doze. Instant messaging apps are unaffected by Doze, so a suggestion to make the Wyze app have High Priority notifications

This results in a minor battery drain, but worth it. If you update your phone or reboot, then you’ll need to reenter this
adb shell dumpsys deviceidle disable

My experience wit IFTTT is that it limits the number of notification events per month, unless there is a paid version with no limits thst I dont know about.

Well, at this point there’s no IFTTT involved and won’t be. Whatever is wrong continues to be so. Audible notifications come very sporadically…sometimes hours in between…and even those which used to show up in my notification panel on the phone as soon as motion/sound was detected are now missing for hours.

It’s all distressing but since it’s out of my control, I’ve had to stop focusing on it as it’s annoying beyond belief. Seems to be a software issue, but what the heck do I know?

Keep me in mind?

Cathie Simmons

I have an Samsung S8 with Android 8. I’ve had my Wyze cam’s for about a year. I’m a high tech kind of person. This issue has been plaguing my Wyze cams ever since I purchased them. It get better with some firmware’s, worse with others. I suggest you keep track of the firmware that works best and make a note of it. I have tried all the suggestions in this thread with no help. I will say that some other notifications get delays also at times, so this may be an Android issue more then Wyze. Good Luck

This is good advice. Right now, this whole Wyze system of mine is working like a boss. Perfect in almost every respect. Drives me nuts. I will make note of the present firmware, but is it possible to revert if an update changes it? Or do I just refuse to accept new firmware?

All of tech is both fantastic and horribly frustrating. I just want it to work, darn it! And that is a pipedream so I must adapt. This forum helps.


Many of the most recent firmware can be found here:


I wouldn’t go back too far though. 2 or 3 back should always be safe. Make sure you choose the correct one for your camera (V1, V2, etc.).

Also, one time I updated the official way through the app and the camera went dead and just clicked. I had to revert back and reinstall the update via the SD card. Kind of a pain but it worked just fine.

Good Luck.

I’ll toss out this, ISPs such as mine, really don’t give a damn if information from your network is handled properly or at all. Customers scream if streaming video is glitchy but hardly anyone yells when stuff from your network is not delivered or not in a timely manner. They have never been forced to provide symmetrical speeds up and down either because that would imply that you are paying for a connection and QOS standard and not for a service they provide.

I’ve found taking notes and intentionally triggering notifications over a period of time give them data and makes them push to 2nd level support.

Also found that if you are using the modem/router box provided by ISP your cameras will be second rate because the router part is massively underprovisioned. It simply can’t handle any significant amount of internal traffic. I tried it on and with my network crashed it over and over till I shelled out for a separate router and switch. Router had 4 times the memory, way faster processor, and ability to handle 4 MIMO data streams simultaneously will still supporting wired in sections.

ISPs don’t want to admit that what they provide is bargain basement stuff because they struggle to handle what they have already sold.

Wyze is a symptom, not the problem.

1 Like

Push Notifications Work, Don’t Work, Work, Don’t. Me too. And just recently, possibly related to the app upgrade to v2.1.31. I share cathiesimmons2’s and Alan-K’s frustration as accounted throughout the thread above.

When I first pointed my new Cam v2 out to my front yard six weeks ago I wasn’t too surprised at the onslaught of notifications evoked by the neighborhood cats passing through. Firmware is

It took a couple of weeks to tweak the detection zone and the sensitivity to create a notification scheme narrowed to visitors approaching my front door while eliminating about 75% of the feline activity. (FYI Sidebar: Occasionally after dark, even though well outside of the zone, as the neighbor across the street backs out of the driveway, the tail/brake lights will evoke a notification.)

Suffice to say I pretty much solidified my familiarity with Wyze notifications and was quite satisfied with it. Worked like a charm and fun with Samsung’s knock-knock sound. Now, it’s Work, Don’t Work, Work, Don’t.

Further, I can get up in the morning and open Events and, as expected, it focuses on the current day. No events (as in Don’t Work). I tap the day before which shows that day’s events. I tap the current day which now shows events that occurred so far from midnight. And then get the sound and pop-up.

And then throughout the day, when I note I haven’t heard a knock-knock in several hours, I unlock the Galaxy and repeat the above today-yesterday-today sequence and find new alerts and get the sound and pop-up.

I’ve troubleshot the heck out of it along the lines of Loki’s three point summary and then some to no avail.

I reject mbernier’s ISP quality blame and feel for his ISP blues, so sad. My Cox 30 Mbps cable service and gear has been 99.99% for years, no issues on devices past and now two PCs, a laptop, a Roku Ultra and but for Wyze, the aforementioned tablet. As well, for about two years my net gear is now my own and good quality and with having 20+ years in network admin and client-side support (MS, Unix, Novell), my LAN is a finely tuned entity, wired and WiFi.

That said, I could accept reasoning that it’s on the AWS side of things…

I’ll try and wrap up the logs and place a support request this week as Loki suggests.

March 30 addendum: I should have also mentioned this is not a deal-breaker for me; the notification feature is not a primary need, though it might be to others. I continue to consider the Cam quality and free AWS Cloud service as the best there is, even for products at much higher price points.

A post was split to a new topic: Netgear router model

Good day,

Has this ever been resolved? My experience has been - right after I reboot my phone (which I do pretty much daily), everything works. ALL notifications, not just Wyze - i.e. emails, IFTTT, text messages, etc. After a while - ALL notifications stop. I have to reboot the phone to get all of them to work again.

If I do not reboot again to restart the notifications, they SOMETIMES resume working and start by spitting out all the overdue ones at once.

Without going into too much detail, I rely on these heavily - to the point that I set the notification sound to something incredibly loud and annoying because I have to be able to hear them and react to them in the middle of the night when I am otherwise sound asleep.

The IFTTT and Wyze notifications are set to high priority. I have not yet tried disabling the battery optimization for the two apps - maybe this will solve it.

Unless I missed it, I did not see a clear answer in the forum here. Is there a resolution?

From what you say, it sounds like the problem in your case goes way beyond the Wyze notifications. Not sure if you’ll get help here, but I’d suggest you try searching/posting on more general Android forums or Google’s support pages.

@Loki - oh absolutely agreed! I was just hoping that perhaps someone has already seen this and tried resolving it. Android support is not as easy to reach, I learned the hard way… :wink:

1 Like