Problem with new firmware update

I had received a new WyzeCam Pan device, and on installing it, was prompted to upgrade to the new firmware from the previous version, so I let it do it through the phone app.

The update seemed to be ok, until it was time to install a memory card, which was a Sandisk Class 10 MicroSD card, which I have used in my WyzeCam Cube V2.

The memory card would not format. I tested the card in other devices, and had no issues with it, including connecting it to my PC and formatting there. I could also write data to it no problems.

I figured that there was a problem with the device and got an RMA for another one. The new one arrived and I had the SAME PROBLEM with that one.

At this point I decided it was either an iPhone App problem, or a problem with the manufacture run, or a firmware issue. I tested with an Android version of the app and had similar issues.

So I reverted back to the previous firmware using the SD Card method with demo.bin on the SD Card root. This went over fine, and the device started working normally with the SD Card. I decided to try updating it again to the new version using the same method instead of letting my phone initiate it, and the device again works fine with the new firmware.

I suspect something in the delivery of the firmware using the phone method is causing this issue. Not knowing much about what it is actually doing (I assume some tftp to pull the new firmware, likely), but either the code it is pulling during this method has a problem with it, OR the phone update method does not write the firmware correctly.

I just wanted to point this out and let you know that was about 2 hours of my life I will not get back, and that Wyze may want to take a look at this issue. The fact that I could reproduce it on the second device cinches it for me.

Best regards,


1 Like

I should consider myself lucky. I’ve done, maybe, 3-4 f/w updates via phone (Android 10) with no glitches.

FWIW. I never format the 64gb Sandisk Extreme cards … i cut open its package and slip the card into cam.

That’s what I had done but in my testing I have determined that formatting them on PC is generally ok, using the SD Card Formatter utility is fine, and using a working device that can access the card to format it all worked fine. The iPhone updated unit just couldn’t read it properly.

I did not actually try updating the firmware using the Android version, I have an iPhone, but use Android through an emulator - it works great… I just never thought to use the Android to initiate the upgrade - I don’t even know if the update has to pass through the phone when doing it that way or if it just tells the device to go download it. I would guess the latter.


Hi! I’ve had the same issue now with 4 pan cam’s and an android phone. I haven’t yet figured out how to fix it. Glad you found something that worked, so I would like to try that, but I can’t seem to find the firmware page. Where did you download the firmware files from?

UPDATE: disregard, I found it using a google search. Will let you/others know how if this works for me too.

Great to hear I am not the only one though sucky for us. Wyze does not seem big on interacting with their forums, which is a shame. Let us know how you get on.


Confirmed, this fixes the issue for me as well. Kudos to @ChexInTheMail
Here’s how the entire issue went for me:
I purchased two Cam Pan’s. When they arrived, they had firmware version and prompted me to update to the latest firmware, which I did. When inserting an SD card, I would not hear the ‘tink, tink’ sound indicating that the camera recognized an SD card. When I would restart the camera with the SD card inserted, the app would show the SD card as available, however, it could not save/playback video from it. Within about 5 mins, the camera would stop responding, then restart itself. I am using 32gb cards that match the specs required. I tried reformating the SD cards, no change. I purchased two new 32 gb cards, no change.

I contacted support. They were super pleasant and sent me two new cameras. When these two cameras arrived, I started the first camera and completed the firmware update same as before. Same issue occurred. I started the second camera and refused the firmware update. Voila, no issue. That’s when I started looking for answers and found Chex’s post. So, here’s the fix: all you need to do is manually flash the latest firmware.

(restating what Chex did)

  1. Download the latest firmware file. (even if your camera has “already” been updated with the latest (identical version) firmware via your Wyze app, just do the manual load with the latest firmware file again).
  2. Format your SD as FAT32 with default settings for FAT32 (in case the camera had messed it up along the way).
  3. Load the firmware file on to the root of the SD card as demo.bin.
  4. Start the camera with the manual flash process as described by Wyze.
  5. Fixed!

If I had to guess what is happening here, I would bet that Wyze has inadvertently released a bad version of the firmware OTA via the app. Downloading the firmware version and loading it manually gives your camera the good version.

It would have been easier to simply use the Beta version, as many of us do … “upgrading” via the app as is usual … vs flashing /copying.

What would be easier is if it just worked. Any of us who can make that work after making these changes is just lucky to be technical.

That’s hilarious (I’m laughing with you on this : )

Make “what” work? The Beta suggestion? If yes. it’s easy peasy. Go to the App Store, navigate to Wyze app. scroll down a tiny bit till you see. “join the Beta” - tap “Join”. After a bit of time, check for an App Update - update it, then check for a firmware upgrade - do so. Enjoy.

This sample screenshot is for another app I’ve not yet joined their Beta, but shows what you’re looking for

No, I meant anyone that would reflash it manually with the SD card at all… Beta notwithstanding. IMO the software is Beta enough as production release… there are multiple issues with the iPhone app version at the least, much less a beta firmware version’s potential for problems. I like my cameras to work reliably, so I am not likely to beta unless I was a hobbyist with extra cameras.

Thanks though!