Problem logging into multiple cameras

I had two cameras… they’re grouped and when I logged on they both came up quickly and were very reliable. I added three more and now they are all less reliable. I have Xfinity for wifi … the access point is literally ten feet from one of the cameras and yet I have connection issues. It connects, then the stream stops. Then starts, then stops. sometimes I get an error code Connection Failed error code:-20010 or -20011

It’s like adding this many cameras they’ve all become unreliable now.

Have you put a support ticket in yet?

What model router/wifi/access point are you using?

I know this sounds silly, but it has to be asked, have you tried power cycling the cameras and app?

Try stepping down from HD. That solved my problem

If you are on Android, perhaps the loss of hardware acceleration is affecting you. You can try downgrading to V2.4.82, the last version with hardware acceleration. Wyze is looking for a solution.

  • Be sure to uninstall your current app before installing the older one.
  • Also be sure to turn off automatic updates.

You can find V2.4.82 here:


I have not put a support ticket in yet … was wondering if anyone else on Xfinity experienced this. I have power cycled everything, yes. I have a call in to Xfinity to replace the router – (I rent it from them).

Hopefully that solves the issue … doesn’t seem like it’s a WYZE thing … seems like a bandwidth thing.

I run off Xfinity but I do not use their router.

Are you on Android? If so did you consider my response in #4?

I’m on iPhone :slight_smile:

Did you try dropping The resolution of the cams. You do not need HD

Yes I can drop resolution… but really I shouldn’t have to.

What iPhone are you using?

There are so many factors trying to send multiple HD streams to your cell phone. Could simply be a memory problem in the phone. Lots of corners to explore. Not necessarily anything to do with the cameras ??

I have the iPhone X (10) also accessing via my iPad pro

That’s a good point too… I’ll try “ungrouping them” I have another group of 3 cameras that behaves just fine (in a different location)

You definitely shouldn’t be having this problem. I am on Xfinity and have anywhere from 4 to 7 cameras operating at a time. I use an older iPhone 6 and iPad Air 2 to watch the cams. You sound much more up-to-date than me, so you shouldn’t be experiencing this issue. I have no experience with the Xfinity router though, I use my own Netgear. I definitely would submit a request with support. They have tools that can help identify the issue.

I did see a similar issue to yours once. I was at my nephew’s house and even though he had fast internet and an AC router I couldn’t connect reliably to my cameras back home. It was such an issue I had to switch to cellular, if you can believe it. So there are instances where an issue may need to be identified.

Here is a link to file a request with Wyze support:

There’s stuff going on in the FB Beta that may fix this. It did for me.

I’m actually going to swap out the modem/router tomorrow with xfinity. If that doesn’t fix it, I will contact support. It’s funny because my other three cameras are in remote Maine and the service up there is only 10MBPS! Compared to my 250MBPS at home. LOL

Jealous of your 250 Mbps Comcast. I only have 118 or so. Tempted to say watching the 10 Mbps cameras may be slow, but I can access my cameras from my sister’s 15 Mbps Cox cable no problem.

@gemniii - They are using modern Apple equipment. Is there a related fix in Beta for iOS?

Not that I know of.
But it should transition I would think.
@WyzeGwendolyn should know. So with that “@” I just summoned her :slight_smile:

1 Like

You may be thinking of the fix for the loss of Android hardware acceleration, which really improved Android performance.