PNY Card failure after update to

I setup 6 new V3 Cameras for my Christmas display, along with some V2s used in previous years.
With 5 of the new Cameras I put in brand new PNY 32gb Micro SD Cards, one used a San Disk 32gb I had laying around. All was working well until Christmas day when I did an (mass) Update to the firmware on the cameras. All 5 Cameras are working, but all 5 PNY SD Cards are completely toasted. They will not write, 3 were not even Recognized by the Cameras any longer, 2 Showed they were installed but showed No Space and No playback history. I put them in my computer and I can read the data from the cards, but I cannot format them, delete any files or anything. They are not showing right protected. But all 5 went down within minutes of each other after the update, I can’t blame the cards, 4 of them have been installed and setup since the beginning of December and working just fine, the 5th was in stalled just Days before Christmas to add another angle to our coverage. And, All 5 cards went down at basically the exact same time. But the 6th camera with the San Disk card is just fine.

What are you doing for a Christmas display? I have been running a music synchronized show since 2014.

Hey, Fully synchronized music show with over 50k Pixels and over 100 inflatables, all Minions.
Around 500 people a night the last few days before Christmas.
Found out about the card failure tonight, someone tried taking off with the Donation box and was trying to review it to catch their plates, but Nothing, all of the V3s covering that area are about useless at the moment. They didn’t get the box, I was watching from the warmth of the house when I saw it and ran out with my 10k Lumen flash light and pew pew, They took off. But no footage as event recording is off to keep it from dinging constantly. So I Was able to get the time stamps off the SD cards and determined that was when I updated the firmware on Christmas day while I was bored and doing some other system updates.
Oh, 73’s (kilo-India-four-Charlie-Sierra-Quebec)

I am having a similiar problem. I have 128 GB PNYs installed in 3 V3s. They all stopped recording in August (I am on current firmware now), but not sure if I had done an update just before. I only realized in the last month that they have stopped recording. I don’t usually have to look, my cloud events are usually all I look at. The cameras all see that a card is installed, but if I try to format from the cameras it tells me there is no card, probably because it can’t write to it.

If I try to format or write to it outside of the camera it tells me it is write protected, but there is no tab to turn on or off write protection. I also agree that it must be the cameras because it is 3 cards on 3 different cameras. I just chatted with support and submitted a log. I am hoping something will be figured out soon.

Since your Sandisk is still working, I guess they must be having some weird issue specific to the PNY cards. I haven’t tried any other cards at this point.

Some more updates, I had 3 64gb PNY cards that I put in a few cameras about 4 months ago, just went and checked those and they are all also reporting an issue with “No Card”
Good Deal? I don’t think so.
Avoid PNY Cards.