Outdoor cam is stuck with rapidly flashing light, no response to 3 tickets

I was in on the early order for the Outdoor and when I received it it worked for a few days after a full charge. I’m as ticked as everybody else that this thing isn’t actually a security camera as it doesn’t record to the card, and the detection capabilities are substandard at best, but now it is just flat out broken.

It discharged the battery completely in about 3 days and is now stuck with a rapidly flashing red light and the button is unresponsive, which is the only troubleshooting tip. I’ve tried it plugged in, unplugged, cycled the power button, even left it on hoping it would just die and reset itself completely. I unpaired it from the app at one point and now can’t get it back to the account since it is completely unresponsive.

Has anybody else had this and have you managed to fix it?

I’ve opened 3 tickets, 2 via the site and one submission for help via the app, and have heard nothing back, after the better part of 2 weeks.

sorry to hear this. can you post the ticket number ?


731029 on 8/13, 740130 on 8/27 (yesterday), and a submission from the app the week of 8/6 or so which I don’t know how to dig back to and pull a ticket number from.