Oops new wyze public app still called Beta

My phone just loaded an updated wyze app and the app is called Wyze beta but I’m not in a beta program. Looks like someone forgot to rename the app before making it public image

1 Like

Sounds like typical Wyze QA…


Have you tried uninstalling and reinstalling the app?
Anyone else seeing this? @Mavens?

What’s the version show in app?

1 Like

I have not uninstalled and reinstalled. I’ve never had a beta version on here so there is no reason for the app name to change to it other than someone left it on the uploaded app to the App Store. I’ve posted the version info the the update list from the App Store above

1 Like

Hmmmm… Yesterday they said they were postponing the app update until next week. Guess not!

V2.18.43 is the iOS app. I just updated my iPhone to it, and the app is just titled “Wyze”. I also loaded it on my iPad, where it OVERWROTE the Beta app, leaving an app just called “Wyze”.

Both of my Wyze apps now show V2.18.43.

So maybe they fixed it? I’d manually delete the app and try again.


To let you know the app still says beta even after new updates and deleting etc

Any news on this? Anyone know how to stop it saying WyzeBeta? I’ve completely deleted the app and downloaded again and it still says beta

You are the only one experiencing the issue as far as I know. As a test, I just deleted my iOS Wyze app and reinstalled it from the Apple app store. It still simply says “Wyze”.


Is your app version 2.19.24 under the Account tab > About?

Yep my app is the same version, downloaded having deleted this morning.

Also looks like another thread with people having the same issue so I am not alone


Interesting. Let me see if I can get anyone’s attention on this.

What iOS version are you using?

1 Like

I’m 14.5 on my IPad and iPhone is the same


14.5 iOS version


Yes I have had this same issue for quite a while now.

My app is now back to the correct name, I assume it was fixed in the latest update

Installed latest app notifications running 12hours behind

Sorry 13 hours behind not 12 and the app is the latest. Not Beta anymore

Haha after almost a year wyze has made the same mistake again and my new app appears as Wyze Beta again. As before I’ve never been part of a beta or downloaded a beta version.

1 Like

Me too. . Attention to detail on pre-launch clearly an issue.