"no video at selected time"

We’ve used about a dozen cams around our day center set to record continuously and they’ve been great. On occasion I get the “no video at selected time” and replaced the card. That solved it. It makes sense the cheap cards will become corrupt rewrite after rewrite.

In the last couple weeks multiple cameras are doing it randomly. Cameras either won’t record at all or record intermittently. We replaced with new cards and it still does it. It is happening on brand new cameras, as well.

Have the recent firmware upgrades had something to do with this? Is another update in the works?


I have tried three different brands; generic, Kingston, and SanDisk. SanDisk seems to always work the best. I replaced all the cards in my cameras with SanDisk and things are working great. I also only used the 32 GB as suggested by Wyze.

one thing you might want to look at is high endurance cards. it is odd that they have all gone out around the same time but I don’t believe it’s in relation to any update.

although some cards will work, just as you’ve said, that constant re-write can take its toll. sandisk goes as far as to admit this and states that use in cameras such as ours will actually void their warranty. high endurance cards on the other hand are made for this very scenario. check out this topic, there is some good take away here.

what sd cards are best for wyze cams


I am having the exact same problem as Kimr55760 and about the same timeframe. It used to be “no video at selected time” was spotty. However since the last update I’ve had to reboot cameras to get it to continuously record again and today history from a few days ago that was there yesterday is now completely gone however it has once again started to continuously record. Any help would be appreciated!

It’s also happening on the cameras after we have brand new cards installed.
I’m thinking our router is dropping out?