New RTSP Binaries for Beta Testing

Nice! Looking forward to upgrading my cameras when I can get to them. Unfortunately, they’re not where I’m currently staying.

Thank you I ended up using a program from seagate. And so far the rtsp is working (with a 7-13 second delay)

1 Like

FYI - @WyzeTao - you linked to a 4.49.bin file, but the RTST (sic) instructions still list a 4.41.bin file.

I flashed my Pan Cam yesterday and the camera shows the 4.41 firmware even though I downloaded and installed what was supposed to be 4.49.

1 Like

Was typing the following post when I finally heard “setup completed”, but going to post in case it helps someone else. The keys here were: after flashing 0.49 unplug the cam pan and take the SD card out. Plug cam in and hold setup AFTER plugging in for 10+ seconds (until you hear a small click) to factory reset cam. Then setup, and voila!

Also during no point did my blue LED turn on, so I think the LED itself may be having some issues. Cam purchased March 2019.

"I have .49 installed on my pan cam, but the connection times out when I try to set it up. It’s set to a static IP so I can ping it during the setup process. I see it connect to the network, then think it has timed out and it disconnects.

I recovered it to November 2019 firmware, then reflashed .49 RTSP. Nov 2019 worked perfectly fine, but .49 won’t hold a connection."

Does this fix the bug of the MAC address sometimes changing (to the hard coded one, apparently)? That seemed to be a fixed bug in the main branch but came back in rtsp, I don’t see it listed in the changelog unless it’s in the generic bug fixes.


I can no longer access my pan cam from the Wyze app and RTSP feed is going in and out every few minutes (although it seems to strongly prefer being offline). Tips?

Edit: reverted to xxxx.41.

xxxx.49 is entirely unstable, and xxxx.41 isn’t much better. I know this firmware isn’t a priority, but it’s really disappointing that Wyze can’t get stable RTSP. I want to buy V3 cams, but I won’t do it without good RTSP.

The update was mainly for the binary to be compatible with our v2 hardware units. We chose a newer base f/w version which is 4.X.6.199. It has more stable code with CamPlus capability.


Yes, same as the current official firmware.


Glad to hear it is working now.

Thanks for the reminder! We didn’t change the official link since we wanted to get a round of external testing first. So far I haven’t see any report for issues. We will update the official RTSP link soon.

1 Like

Likely it wasn’t flashed for some reason. Please unplug the power, insert SD card, ‘press & hold’ the setup button and plug in the power cord, wait until you see the LED light changes from yellow to blue and then release the setup button. Good luck on it!

Happy to report that the beta V2 rtsp firmware allows me to bring it up on alexa (show/spot) again. I’m guessing something with alexa made it incompatible for at least a month now, maybe more. This new version brings back functionality that worked when I originally went to the rtsp firmware.

Additionally, rtsp seems to be running much smoother – I used to get frames missing, but now it is flawless for 20-30 minutes I watched the stream.


1 Like

That’s what I did the first time, but maybe the flash didn’t work for some reason. I’ll try again and see what happens. Also going to flash one of my V2s.

We can’t tell the problem unless you provide a log with us. You can insert an SD into camera, wait until two chime sound plays, and then pop out the SD card. There is a log_XXXX.txt file on your SD card’s root folder. We can take a look if you share with us via DM.

Have you try to not assign static IP for the camera? I don’t know if that plays a role there. There is a possibility of IP conflict. Can you temporarily allow DHCP for the camera and see if the behavior is different?

Yeah let me get you the log, thanks for taking a look. What do you mean IP conflict? What would it conflict with? If I don’t assign a static IP how do you recommend setting up my RTSP feed?

Just reflashed the Pan and now at Not sure what happened the first time, but now it is installed.

I reflashed my v2 after reading your reflash post about your Pan and now RTSP is working, Thanks for posting.

So far so good, I use my v2’s with my Synology Surveillance station and the new firmware is much more stable.

I have the same question. It’s the only problem I’m concerned about.