Need to return vacuum for replacement?

Today I found this article on the Wyze offsite:

is it saying: " it does mean is that if your Wyze Robot Vacuum isn’t set up using the Wyze app by 1/20/2021, you’ll need to ship it back and we will need to send you a replacement which could take a few weeks."

I have received mine on Jan 23 and obviously I haven’t set it up before 1/20.
Does it mean I have to return it immediately?

Same boat man, vac wont set up. Waiting to hear back!

Can you try setting it up?
If you have issues, You may want to contact Wyze Customer Support about this issue!
By phone: (206) 339-9646 Available Monday - Friday 5 am - 6 pm PT and Saturday 8 am - 4 pm PT

We’re kind of just waiting to hear from wyze on the issue. If they can put an update out or something that fixed the wifi setup issue…

I recieved mine yesterday and tried to set it up for hours. Did all the steps, troubleshooting steps, tricks and possible work arounds. Only fix I believe is to fix the bug in the app very soon, or send out return Shipping labels with refunds. Best way to avoid a class action lawsuit. I give it 1 week.

Hi @Omarrie1229 and welcome tot he community Forum. :slightly_smiling_face:
Greetings @eugenyk @christianolson292 @shane.ppikelin

If you haven’t already opend a support ticket with Wyze, please do so.

Post the Support Ticket number here and indicate if this is the first time you are setting up the vacuum or if it was previously installed. Indicate if you using Android or iOS and what is the app version number you are using.

If you are using iOS please make sure you are updated to v2.16.48
@WyzeJasonJ is tracking this problem.

1 Like

I did try to connect about a hundred time using all advices from other threads here. Nothing helped.

[Wyze Ticket 1011566] We’re working on your request: Robot vacuum recieved on 1/24/2021 not connecting
[Wyze Ticket 1011336] We’re working on your request: Wyze Vaccum

1st time set up, recieved it yesterday. I’m on android and I have the updated app version. v2.16.55

Besides all of the tips, troubleshooting steps to take, resetting my router, factory resetting…etc I can go on. Does not work.

Small suggestions for the Wyze team. This is a great product if it worked correctly, but to understand our frustrations on the forum is to take a new bot fresh out of the box and try to set it up as of today. You may run into our problems and know a fix or possibly know where to start.

(Wyze Robot Vacuum Setup Issue - 1/25/21)

1/25/21 10:00 AM PT - We are looking into an issue that is preventing Wyze Robot Vacuum setup for some customers. We apologize for the difficulty and will post updates here when we have them.


1 Like

Thank you!

I’m in the same boat, got mine on late-night 22nd. Having ‘Request binding failed’ type of error during the WiFi setup. I’ve seen info in a separate thread somewhere here on the forum related to the expired certificate on the vacuum. If that’s the case, they won’t be able to fix the connectivity problem and the only way is to send it back for the replacement (or direct firmware upgrade of the vacuum via USB if such option is possible for end customers like we are). Not sure if this is true or not. Anyway, I’m still waiting until this Friday, will return the defective product if the problem is not resolved by then. No more Wyze for me, such a disappointment.

Hi @weak-head re: expired certificate
. . . all customers using Wyze Robot Vacuum should make sure they are using at least the 2.16.55 Android app or the 2.16.48 iOS app due to the recent certificate update.

(Wyze Robot Vacuum Setup Issue - 1/25/21 - #39 by WyzeGwendolyn)

Todays update of the app for Android to version 2.17.7 haven’t helped with this issue at all. vacuum wifi still disapears right after starting “Connecting”…

Looks like we have to send vac back for replacement:
1/28/21 10:50 AM PT - We have identified a timing issue that could cause devices to fail the setup starting when the issue was first reported. We deployed a fix that will prevent it from happening again and are waiting for verification that this fully addressed the problem.

However, devices that failed setup between 1/21 and 1/27 will not be able to be recovered by customers. If you have been impacted by this issue, please reach out to Wyze Customer Support for a replacement.

Anyone had any luck contacting support about getting a return label and a replacement? I have a ticket opened from my initial complaint about not being able to setup, but I can’t get them to reply back to my emails in that thread.

The same here. Finally I called them, talked to the guy and now awaiting for shipping lable by email. Still waiting…