Links don't work

Has anyone at Wyze noticed that the links across the top of the home page haven’t worked for over a week? You know, the links for “Shop”, “Forum”, etc. They change color when you click on them, but nothing happens. Maybe no one at Wyze cares. Maybe they are working on landscape mode and are just too busy to notice. Bwahahaha.

This is a community forum. To let Wyze know of potential issues like this, you could reach out to them via phone: (206) 339-9646 Available Monday - Friday 4 am - 8 pm PT and Saturday 8 am - 4 pm PT, or online:

However, I assume this is from a standard Web Browser, correct?

Which Browser are you using and from which OS?

I use a Chromebook with Google Chrome as the Browser and don’t have any issues with the links at all. Have you tried clearing your Browser Cache and rebooting the computer?

Seeing that you use iOS devices, I also test on my Macbook pro and Safari, no issues with that browser either.


Working fine for me on a Windows 10 desktop using FireFox. I note that most of the open a new tab. Do you have a popup blocker that could be blocking the new window or tab?

1 Like

There is no way to directly contact anyone at Wyze and I’m not spending hours on hold just to tell them that something else doesn’t work. Too many things already don’t work.

1 Like

I am others are not having this issue.

Can you post a pic of what you are seeing on your screen. Also provide the environment you are using so we can see about duplicating it.

1 Like

The links work on my iPhone, but in typical Wyze fashion they do not work on my iPad. The Wyze programmer has never been able to figure how how to program for IOS and this is just another example. Can you say “landscape mode”?

I have an iPad as well. I tested in portrait mode and in Landscape mode and it is working without issues. I attached the Magic Keyboard and at that point, you have to use the trackpad to navigate via the menu.

I really would help if you recorded a short video of the issue you are experiencing.

In addition to posting a short video, I would open a ticket and submit a log as well.

As a Beta Tester I use Android Phone and Tablets and iOS Phones and iPads. I have not been able to reproduce this issue on any of those devices including a Chromebook, Mac Book Pro, or a Samsung All-in-one PC.


Same here… links working on my iPad Pro 12.9 running iPadOS 15.3 with Safari. Also working on my iPhones and Android devices.


Well, it only took a month a half, but they finally fixed it. lol