Latest Firmware update for V3 causes major video stutter

I reported this last year. I upgraded 2 of 3 V3s to the firmware after 4.36.9.139. The videos of the 2 V3s immediately started displaying the stutter from both the cloud recordings and the SD card. The stutter was evident from both my Android phone and tablet, which were on very different versions of Android.

Videos recorded prior to the firmware upgrade did NOT display the stutter, and no videos on the V3 that I didn’t upgrade ever displayed the issue.

I of course restarted and did all the trouble shooting to the two upgraded V3s. I even tried to upgrade one again, but that didn’t help.

I then fell back to 4.36.9.139, and the stutter issues were immediately resolved.

I know that not evey V3 had this issue, but a significant number did, so it’s not just a fluke of bad luck.

But based on my experience, it was a firmware thing which clearly only effects some (but a significant #) of the V3s.

1 Like

I was hoping we could get this added to “fix-it Friday”, but it did not make the cut.
When an event from a V3 or V3pro camera (via Cam+) plays fine from Webview, but stutters on the Android app side, it must be something in the Android app?

AGREED!

Unfortunately I have not been successful in going back to the 4.36.0.139. Otherwise I would and my stuttering issues would be resolved.

Thanks!

Maybe you are aware of this, but you can’t just load that version from the card. Going back to 9.139 requires doing the factory reset of the V3 cam. You might have done that, but when you said you were unsuccessful, I thought it was work mentioning.

1 Like

Thank you! Yes I did do the factory reset etc. Unfortunately it did not work.

But thank you for mentioning it.

My videos. Start fine, 3 sec, then just freak out, black screen, pixelated images of things that move, looked like mpeg compression bug?

So I wanted to give an update to my purple cam issues. I had upgraded to this firmware and 5 of my 6 newly purchased cam 3’s started giving me that purple screen and flicker (videos above). I tried upgrading to the newer firmware that rolled out after this one and it didn’t help. So ultimately I went back to 9.139 and that seemed to work but I did have to do the setup process for my cams again. If you rename them the same name you had them, the camera settings in the wyze app are retained by the way. Additionally one of the cams that was working with this firmware seemed to upgrade to the newer firmware just fine.

Purple usually is an issue with Night Vision. Check out post #2 on this link.

Well in my particular case I know it was caused by the firmware update but only on the home depot 2 pack models. Mine also had flickering which happened one time without the purple and it looked like a light being repeatedly turned on and off… on video anyways. I don’t think I had a sd card in at the time or I could share. I tried the fixes it mentioned and none worked. I tried resetting, cycling night vision, unplugging and plugging back in over and over, and even updating the firmware but nothing worked until I reverted to the previous firmware… the firmware it came with. Maybe my cameras are defective but they are working with the older firmware for now.

2 Likes

Thanks for posting all the updates! :+1:

Some of us aren’t saying much recently, but paying close attention and leaving our Home Despot V3s safely back on 9.139.

1 Like

How can I force an older firmware onto a camera?

It’s pretty straightforward, just take your time, use only a 32 GB card to do it, and it usually works well. Links below for various cam models.

The first ‘trick’ is that every time ( well maybe not ‘every’, but it sure seems like it ) the phone app updates, it will offer to update the firmware also. So on the cams you want to hold back to older firmware for whatever reasons, just check “don’t ask again” and hit ‘Cancel’. If you use a bunch of phones and tablets, it will probably ask on each and every one of them.

The second and biggest trick is to always read this forum before doing any updates and learn from the people doing the experimenting! :+1: :+1:

1 Like

Where does wyze stand on fixing issues? Do they use GitHub/Lab etc?

There’s a bunch of independent use-at-your-own-risk stuff for Wyze cams on GitHuib - Xiaomi-Dafang-Hacks , docker-wyze-bridge , RTSP , etc, but I try to mostly just save firmware files that Wyze posts on their website.

Then if something breaks I can flash backwards until the device works again for my needs while understanding I am giving up new features.

Wyze definitely seems to be constantly working on fixing things and adding features, but their priorities may not always line up with your or my priorities.

Reading what the beta testers and forum mavens post usually gives me the best idea of what might get fixed next…

Would love to see an update to sprinkler firmware. Currently barely usable IMHO.

For reference sake, adding that following the 2.44 RC beta update of the app, the Pan v3 also stutters during event playback. It’s disappointing that this issue has persisted for over 10 months without resolution and now affects multiple devices.

What is wrong with software development at wyze? How could this error propagate to other devices?

1 Like

YES!! Same here with 6 of my 7 cameras. Contacted them multiple times and always talk to a “tech” that hasn’t a clue about networking or even how their system works with AWS, etc.

Practically impossible to get to talk to someone who has a clue. Always want you to spend fifteen minutes resetting, unplugging, etc.

The problem is theirs and it pmo they act stupid and never address this issue.

Three years ago they were a whole different company. Now, they have decided to diversify their product lines way past their ability to support them adequately. They used to provide a good product and service. Their greed will eventually destroy them unfortunately…

I’ve read many have this same event playback issue. It’s unfortunate I bought into their ecosystem then…

2 Likes

Am hoping for an update to the sprinkler device. The interface is not being updated and has usability concerns. I too bought into the wyze story. Hope it’s more than a VC company that acquires without vision or perspicacity.

I started this thread last year, and I totally agree with your post. I have given up on Wyze, in that I went back to the 9.139 version of firmware (which is the last version that actually works 100%) for my v3 cams and I just don’t bother to upgrade the firmware or the app.

I mean let’s face it, all the updates to the firmware are bug fixes, and they break something every update and still haven’t fixed this problem. Since the issue only impacts some hardware, apparently it’s just something Wyze is willing to live with/ignore.

3 Likes