Latest Firmware Update (3/2) has caused compound connectivity issues (please help!)

Issue started upon firmware update to latest version on my Sense Hub.

Hub drops connection and reconnects approx. every few min (5 ish).
Before it drops connection, you can add devices and things work.
After it drops connection, you can see that the hub reconnects, but it will not allow you to add devices to it, and it will not play any sounds when sensors are opened. you can soft reset it, but the same issue will occur after roughly the same time period.

Original network setup was DSL modem to main router to AImesh node (hard wired to main router), hard wired to wyze sense hub.
This setup has worked for just under a year with no connectivity issues before the update.

I am using:
Note 20 ultra with updated wyze app.
Latest firmware on Wyze sense hub.

I have tried:
2 different phones.
2 different known good routers and modems (I have 2 bonded DSL modems on separate buried lines to the house)
2 different wyze sense hubs (one new in box as a control)
connecting via ethernet or wifi. Same consistent result.
Resetting to factory defaults and deleting the sense hub in the app (and re adding it) will cause the Sense hub to operate for around 5 min like normal and allow me to add devices… then it will yield the same consistent disconnect/reconnect and then once reconnected will not chime upon sensor open or allow the addition of devices.

So, I contacted support and they basically told me to:
A) submit a log.
B) wait for a firmware fix

This is a rather unacceptable as a solution as it leaves my system unworking in the interim with no way to use it.
I would gladly revert to an earlier firmware version if that was an official option.

Please help!!