Initial RTSP testing feedback


HASSIO VM (0.92.2) is working for me. Streams show up but drop intermittently due to RTSP going offline at the cam.

(Confirmed by testing with VLC when it drops from HASSIO. When you try to access the cam using RTSP via VLC you get an error that it is not available).

Experiencing this exact issue with both Wyze Cam v2 and Wyze Cam Pan. Cameras stay connected to network, continue to be accessible via the Wyze app however RTSP stream dies after a while, sometimes after a few minutes sometimes after many hours, neither seem to survive beyond a day. Going into the Wyze app on the phone, navigating into RTSP settings, clicking Regenerate (making no changes) causes the stream feed to immediately reconnect and start working again. Validated with multiple clients, Blue Iris is my primary but also confirmed same behavior with VLC player.

This has been reported on multiple beta threads and Wyze has already indicated that they are working on it…

1 Like

This is great news - I haven’t been able to integrate with synology successfully. Could you tell me your settings? I don’t know what source path and port to use. The web address the RTSP setting in the wyze cam app doesn’t seem to work in a browser either.


How did you add it to surveillance station? I don’t seem to succeed…


Here are the settings I used (below the italic words would be your specific parameters such as your unique password, username, ip address, etc)

Camera Name: (enter anything you want to call your camera)
Brand: [User Define]
Type: Streaming RTSP
Path: username:password@IP address:554/live

Hi, unless you have an RTSP plug-in on your browser, the RTSP:// address won’t work there. The source path and port I have used is: username:password@IPAddress:554/live

i tried with port 554 now, as you said, but Cameratest still failed.
Where did you get that port number? Could it be another? What else can I try? Can regenerate work?

I haven’t tried any other ports. 554 is the default port for RTSP. Have you tried the “generate camera URL” feature in the Wyze software? It is possible my RTSP firmware (which was the beta version) is using a different port than the newer official RTSP software they released. Interestingly enough, in HomeAssistant, I used the same URL, but left the :554 off and that seems to work in that program (without specifying any port).

yes, when the url is generated it gives an url without port. and that url fails in Surveillance station.

That’s a bummer. Sorry it doesn’t work for you. For me, it is working just fine. Maybe I got lucky with the right combination of firmware and surveillance station version, or something like that. I really don’t know what else to try to get it working for you. Good luck.

1 Like

Yea, this doesn’t work in Surveillance Station at all. In fact I have another camera where just like, this, it works fine in VLC but not in SS.

This has been an issue since about 2 years ago when whatever update Synology did to SS broke my other cams and it’s now creeped into this situation. Lame… ;(

You’re right! I had it working at one point, but due to some updates it stopped working ultimately. :frowning:

Did you try with the latest release? RTSP v2-4.28,4.41

Yes, just updated the latest firmware on WYZE and Surv Station. I actually just installed earlier versions of SurvStation when there was no RTSP (you entered in the port manually) and it actually tests ok but then fails on the save so I think there’s something up with the internal settings of my Synology.

I’m using a DS918+ with Celeron. DSM 6.2.2-24922 Update 2

I suspect it’s my model as I’m betting those with successful running systems are not this.

I’ve opened YET ANOTHER TICKET with Synology Support. They had no clue last year. Hopefully they can find the programmer who wrote this and ask him a very simple question which is what would cause a working RTSP URL in VLC to fail in SS? Specifically, older versions where you had to put the port info manually, it WORKS ON THE TEST but when you go to save it, it fails!!! That’s VERY VERY specific and should be a stupid easy trigger to fix.

However this latest version(s) fail on the test so that routine to test prior has been removed.

SUCCESS with RTSP + BETA Wyzecam v2 version

@ Synology DS1618+ (Intel Atom C3538 ~ 2.1 GHZ) using DSM 6.2.2-24992 and Surveillance Station 8.2.5-5850

  • v4.19.4.48 SUCCESS
  • v4.28.4.41 FAILED

@ VLC Version Vetinari (Intel 64bit)

  • v4.19.4.48 SUCCESS
  • v4.28.4.41 SUCCESS

@ MotionEyeOS 20190427 on Raspberry Pi 2

  • v4.19.4.48 SUCCESS

@ MotionEyeOS 20190427 on ODROID XU4

  • v4.28.4.41 SUCCESS


Synology DS918+ (INTEL Celeron J3455) using DSM 6.2.2-24992 and Surveillance Station 8.2.5-5850 = FAILURE

This is according to Synology due to WYZE not properly handling bad and forth hand-shaking correctly yet I feel this is at a windows or Surveillance Station level.

VLC DOES WORK but allegedly does not wait for back and forth handshaking.

The fact it works on your Synology may indicate an issue with the DS918+. Synology refuses to do anything about this so far.

I’m thinking about purchasing a Wyze camera, and maybe using RTSP firmware for synology. What’s the latest about this compatibility? Essentially what’s you feedback guys - will RTSP cause me headaches?