IMPORTANT FIRMWARE UPDATE: Wyze Robot Vacuum 1.6.97 and Wyze Plug Released - 1/18/21

What did they do for you?

When I was having issues with my vac, Wyze sent me a USPS return label. Haven’t heard anything back them for close to two weeks. ( no, package received, no, we have credited your account, nothing) I was never able to speak to a actual “human” at the company when my robot was down. Cant say that I am a fan of Wyze, they tend to leave people hanging. Sound like you had a little better luck than I had.

Updated with no issues - thks for the map edit - named the rooms, and re-programmed cleanings. works great.

The help support told me if we send it back it could take up to 2-3 weeks before we receive it. Maybe that is what is going on? Hopefully.

You can add us as a “me too” :angry:. After trying to get an answer about the shipment being missing since Dec 20 (FedEx showed never received), out of the blue, a new shipment arrived Friday. No notice, no contact, nothing to let me know to expect it.

Customer support is pathetic.

Now, it won’t connect or update. The process, like others fails at connecting and the local AP from the vacuum is never available to try again. I have tried all of the “chicken dances” reported around these issues and wasted 10-12 hours.

I’m inclined to send it back and wait for Eufy to produce one.

Yeah, unfortunately I’m sure it has nothing to do with our configuration. The connection to the wyze/china mothership is the problem. They shipped these vacuums with a server config that isn’t correct. The AWS server setup changed from what all these vacuums were set up with. Wyze needs to find a way for us to update locally, not via the regular app.

Anyone experiencing connection issues can you let me know if this is the first time you are setting up the vacuum or if it was previously installed. Are you using Android or iOS and what is the app version number you are using.

If you are using iOS please make sure you are updated to v2.16.48

1 Like

First time setup. Both iOS and Android. Old 2.4g phones motorola x, moto g, newer phone S10 5G. Wyze app beta version 2.17.6 Also dropped from beta and installed version 2.16.55, iphone 7 app version 2.16.48), older ipad and Android tablets. Turned off 5ghz on router. Installed 2.4ghz only AP to try that also.

1 Like

Two different Android, first time, app 2.16.55

1 Like

I am attempting to install the vacuum with an iPhone X iOS version 14.3. I am using the v2.16.48 Wyze app. I am connecting to a Linksys Velop mesh network. The installation routine stalls at the point when the vac attempts to connect to the network and provision the app.

Though the provisioning process doesn’t complete, my network monitoring app shows that an IP address has been nonetheless assigned to the vac: on a 2.4 GHz connection.

I have tried every possible approach to competing the installation including uninstalling the Wyze app and reinstalling it. Very frustrating and a huge waste of time. Your assistance is appreciated.

1 Like

Vacuum is attached to my network currently. Just not in Wyze app.


What davidwoodard1 said, it connects to my network and then nothing

1 Like

First time for me using wyze beta app and android…never connected…

Also on iOS, app version 2.16.48. iPhone 11. Eero network (can disable 5GHZ for situations like these for easy connection).

Vac shows up as joining Eero network, but will never show up in the app and always flashes white like it is looking for network setup.

Same issue. If the vacuum gets stuck and you manually reposition it, the mapping function goes haywire and the vacuum doesn’t find home.

Additional Wyze robot vacuum issues reported to Wyze but customer support is nonexistent! I have several Wyze devices and CAMPLUS subscription and was pleased with those products and jumped the gun to preorder the robot vacuum. It is buggy with all kinds of mapping issues (incomplete maps, reoriented maps, etc).


just to update. I was able to contact support last week, and it was quickly determined that an RMA was required given that it was not responding to any button commands besides turning it off and on. A day or two later, they confirmed shipping a replacement and provided me with a return label for the non-functioning device. hopefully, they can investigate what happened with it (still assume the firmware update failed during update) and prevent it from happening again.


Hi, folks!

Sorry I haven’t been super active here. Some general updates:

  • There is a setup issue that we are investigating that is separate from the need to update the app and firmware. Many people are able to set up their vacuums (we can see success on our side) so it isn’t impacting EVERYONE but it is a problem that we are treating as a top priority.

  • We are working on the mapping issues and I’ve been sending feedback about them to the team.

  • The firmware deadline is no longer an issue (not just because we passed it already but also because we found a way to limit the impact that was coming).

Thank you for your patience!


I was curious …How is Wyze handling the return policy? If it’s thirty days and you now “own” the vacuum, can you still return it for a full refund if the robot still doesn’t meet your needs? Obviously “we” are the Guinea pigs here while Wyze is working out all the problems ( And there are many) Please fill us in.