IMPORTANT FIRMWARE UPDATE: Wyze Robot Vacuum 1.6.97 and Wyze Plug Released - 1/18/21

What do I do if my service is interrupted? I received mine yesterday and have tried for hours and have done everything possible and I can not get it connect. I am getting frustrated with this and need help to figure out how to update the firmware when it will not connect at all. Thanks


My map used to be like this before the firmware ,no problem at all with schedule or scanning.

1 Like

Now evertime it start a schedule cleaning it mess up the map,if i send it manually to clean a zone it can habdle it but schedule have all sort of will not a clean a specific zone by schedule ,just the whole house, sometime it lost his north or will crook the map, thinking about deleting everything and start from scratch

1 Like

I received my vacuum today 1/23/21. I cannot get it to connect for firmware update that was supposed to be updated by yesterday…so now what?

@WyzeGwendolyn anyone…do I need to send this thing back?

Let me know if you find a way to get it updated. I received mine the 22nd and having the EXACT same issue.

I’ve tried everything…and it won’t respond

I think it will need to go back…yay!

The problem is when sending it back it can take 2-3 week before you receive a new one.

I was on the phone with tech support level one. She told me it could take 2-3 weeks to receive it if I send it back. Of course they didn’t know what to do, so they are turning me over to tech support level 2. Now I’m just waiting to hear back.

I’m on hold with support…

Good luck! Can’t seem to get up with anybody. We waited 55 mins on hold and finally got an answer. Now just waiting to hear back.

So will I get a prepaid label to send it back?

I have no idea. I’m waiting to find out what the next step is as well.

I tried a factory reset with no avail.

Many, many vacuums are going to go back unless they find a way to update all of these. I think they need to make a separate app that doesn’t have to talk to the mothership to get these updated with the correct server side info. I have another Chinese vacuum that had to use a separate app to update before I could use a new app they put out. The vacuums seem to connect to the phones and such, just not to wyze. A separate update app is the way to go.

It’s definitely disappointing :disappointed:


Me too. It’s so frustrating.

If you find out that they released a separate app, please let me know. Thanks!

That’s what they did for me. Couldn’t wait to get rid of it. Its been over a week though, haven’t heard back from Wyze yet.