I tried using the wyze app with mcdonalds wifi, but the app won't even fully load & gives me a 'network timed out' message

Like the title says, it just shows the wyze logo and freezes there with a pop up message at the bottom saying ‘network timed out’.

Do I have to be connected on the same wifi network as my wyze cam v2’s to be able to view them on the app? If not, what’s the problem?

You don’t have to be on the same wifi, but it wouldn’t surprise me if McDonalds has a firewall or port blocking in place that prevents connection. You could try connecting to the cameras at the same location but with your phone’s cellular data connection (turn off wifi). If that works, it’s a good bet that McDonalds’ internet is the problem.


Thanks! Thing is I don’t have data :frowning: I think I’ll try another location like my library, but I fear they probably have similar firewalls setup too.

Libraries tend to be more open with their internet. While I haven’t tried accessing my Wyze cams there, I did access my Foscams a few months back without any issue.

1 Like

Yea it works at my library, so youre right

1 Like