I signed up for a Cam Plus subscription but cannot assign it to my cameras

I got my Wyze cams, and set them up. The app suggested I subscribe to Cam Plus. I clicked on the button, it took me to the Google Play store and it subscribed there.

People go to the Google Play store because that is where the Wyze app takes you to subscribe. Once you do though, Google says that the transaction goes to Wyze because they get the money. Wyze says ask Google.

It has nothing to do with Google, because Wyze themselves send you there to subscribe.

By the way, if you’re in Canada, the Wyze website directs you to Wyze Canada and you cannot buy a Cam Plus subscription through Wyze Canada. You HAVE to go through the Google or App store.

So did anyone figure out why they couldn’t connect? Because I have the same exact problem. And I got the same exact answer! And the person who I was chatting with was such in a hurry he exited out before I even read the last thing he wrote to me! :woman_facepalming:t2:

Welcome to the User Community Forum @aboovaaj!

A couple details are needed to troubleshoot why you can’t assign cams to your newly purchased CamPlus licenses.

  • How did you purchase your CamPlus subscription? Thru the Store Tab within the Wyze App, Wyze Website, or iOS store?

  • How many CamPlus individual licenses are “Unassigned” in the Account>Services>CamPlus tab of the App.

  • Are your cams shared with any other user?

  • Are your cams currently on a Free Trial Period subscription?

  • Are your cams assigned to any other type of subscription: CamPlus Lite, a separate CamPlus Free Bonus Subscription, CamPlus Pro?

  • When you log into the services.wyze.com website, do you see your newly purchased CamPlus subscriptions listed in your subscription list?

1 Like

Nope. Still the same problem.

Still the same excuses. Honestly, return them and get a refund if you bought them in Canada. Buy something else, and make sure you cancel your recurring subscription

Possible workaround for some people.
Assign the free license to another camera then you can assign the purchased license to the camera that had the stuck license. Or at least that worked for me. :slight_smile:

I had the same issue after purchasing a cam plus license and wanting to apply it to a camera that had a trial license attached. I found I couldn’t assign the license to the camera I wanted. But after some fiddling about I was able to assign the trial license to my pan cam and then I was able to assign the subscription license to the outdoor camera. YMMV.

1 Like

I thought I made a comment in here before. Maybe it was one a different one. Anyway, I had the same problem. I ended up calling the number given for tech support and was told it was a problem at their end. They ended up giving me a refund and then I turned around and bought a new subscription from their site instead of through amazon. Then I was able to assign it to the new subscription and they tech was able to broken one go away. But after a few weeks it appeared again, so I just leave it alone.

Same issue, tech support’s suggestion of removing/re-installing did nothing.
I’m in Canada. Bought Doorbell Pro but before introducing to my network
(literally sitting in car of store parking lot) I installed the app and signed up for
Cam Plus in Google Play as I wanted to be ready with all features once installed.
This may have contributed to the issue and I wonder if that’s how it started for others. I have the
Unassigned camera. It, however, did get applied but as I set it up the speed was slow
even right next to router. Since you’re unable to change to a different network in the
app I just removed device and reinstalled it, this time on my 5g band. It was faster now but
was showing one license and 2 devices, doorbell pro & Unassigned. I just used Doorbell Pro
name in list. A few days later I bought the V3 cam and accepted license from Wyze in-app
and now shows 2 licenses with 3 devices; Unassigned, Doorbell Pro, V3 but I can only use the
one license as when i select Edit Plan it still will only select one camera, not 2. Odd.
Guess I’ll have to wait out the Google Trial (already canceled the renewal) and see what happens as i reset and re-introduced both cameras but still only one camera is able to use Cam Plus regardless of showing 2 licenses.

Welcome to the User Community Forum @shaune!

Sorry you are having those issues. It does seem that the Trial licenses do cause a problem when trying to assign that cam over to a paid license.

I do not use any in app purchases for anything as I would rather buy directly from the Wyze Website and deal with them directly. So, I haven’t had any experience as to how the App Store licenses operate.

You are probably doing the best thing by waiting out the trial(s) until it expires. Post an update when it does!

@SlabSlayer thank you for the reply. I fixed the issue.

Because I am impatient I decided to try something different.
I saw a video by Wyze stating to reset camera(s) before selling
(which is an easier process then the competition’s) so I just removed
the devices from my app, signed out, created a new account (@Wyze.com)
using a different email address of mine. I then added the devices and said yes to the free 14 day
trial that pops up. Rinse & repeat to the second camera, and low and behold, both cameras
are now showing as they should with their respective trial license.
REMINDER: for those who are attempting this and still within the Google Play Store
Trial period, don’t forget to cancel it before it renews - this can be done via the Play
Store under the ‘Subscriptions’ tab.

1 Like

Hi there, yes purchased Thru iOS App Store, months and months, probably a almost a years worth of licenses.

Never knew to go directly on Wyze. My fault trusted Apple App Store and never really followed up with you.

For now on I will check with you first!

Thank you for being kind.


Are you currently having issues with your App Store Licenses?

Word from Wyze is that they are trying to work with the two app stores to try and get them to be more flexible. They have definitely caused more frustration than is necessary.

Yes I was, but I stopped everything for 1 month to see what happens.
It took a month or two to use up all my purchases from the iOS App Store, I don’t know how that happened but just out of them all now and waiting.

Then I guess go through WYZE directly?

I always recommend that users unassign their cams from the app store licenses just before they expire or they are cancelled.

There seems to be a trend of app store subs holding on to cams after the sub expires or is cancelled while still assigned.

But yes, if your subs have all expired and your cams are unassigned, you can go to your Wyze account at services.wyze.com and purchase your subs. They should then show up in your App Account → Services so you can reassign your cams to them.

1 Like

That’s what I did after realizing I should’ve gone through the web site after the 1st one I got through the app. All the rest were purchased through the site. This one will expires in Feb. and I plan on stopping that before going to the web site to renew it.

Thank you very much. I appreciate you clear wording. I will just go onto WYZE site directly and then assign from there.

Yes I agree they do hold on to them, and they talk about 3rd party apps, ok…

Have a good weekend.

Thank you,

Sometimes your not really sure and you just try.

Thank you also for your words. I appreciate the help.

You can only purchase subscriptions from the Wyze Website and manage your current subscriptions and payment method. Once purchased, assigning the cams to the license has to be done in the App: Account → Services

What 3rd party apps? Is this something the Apple App Store does? I have Android and don’t use the Google App Store for my Wyze subs, so I haven’t experienced this or read anything about it.

Hi again hope all is well,
Issue: cv3 to cam pro subscription with no connecting in the Wyze app.

I’m back again with the same issue I have had and you answered (thank you ) and advised me. I did what you recommended which was let all subscriptions run out, and then subscribe through the Wyze app. That’s what I did but I paid for it with my Apple Pay account. I thought that I was purchasing it directly from Wyze on my iPhone. Being right in with within the app. Not …
I have read before when someone else had it and did what they were told also, and still have the issue.
If I may please ask again?
I tried what you said and still have problems with new subscription I just purchased?
I have an apple and thought I was purchasing it directly from Wyze with Apple Pay ?
I can not assign my camera to
The subscription.
It keeps saying unassigned.
I have done this over and over not succeeding.
I’m not a newby with Wyze and reinstated my subscription after waiting for them to run out as advised, but cv3 to cam pro subscription no contracting in Wyze app.
Please advise, thank you

Didn’t use services.Wyze.com
Ok oh my, went off my phone on the app instead of directly going onto www.services@wyze.com