I signed up for a Cam Plus subscription but cannot assign it to my cameras

Possible workaround for some people.
Assign the free license to another camera then you can assign the purchased license to the camera that had the stuck license. Or at least that worked for me. :slight_smile:

I had the same issue after purchasing a cam plus license and wanting to apply it to a camera that had a trial license attached. I found I couldn’t assign the license to the camera I wanted. But after some fiddling about I was able to assign the trial license to my pan cam and then I was able to assign the subscription license to the outdoor camera. YMMV.

1 Like

I thought I made a comment in here before. Maybe it was one a different one. Anyway, I had the same problem. I ended up calling the number given for tech support and was told it was a problem at their end. They ended up giving me a refund and then I turned around and bought a new subscription from their site instead of through amazon. Then I was able to assign it to the new subscription and they tech was able to broken one go away. But after a few weeks it appeared again, so I just leave it alone.

Same issue, tech support’s suggestion of removing/re-installing did nothing.
I’m in Canada. Bought Doorbell Pro but before introducing to my network
(literally sitting in car of store parking lot) I installed the app and signed up for
Cam Plus in Google Play as I wanted to be ready with all features once installed.
This may have contributed to the issue and I wonder if that’s how it started for others. I have the
Unassigned camera. It, however, did get applied but as I set it up the speed was slow
even right next to router. Since you’re unable to change to a different network in the
app I just removed device and reinstalled it, this time on my 5g band. It was faster now but
was showing one license and 2 devices, doorbell pro & Unassigned. I just used Doorbell Pro
name in list. A few days later I bought the V3 cam and accepted license from Wyze in-app
and now shows 2 licenses with 3 devices; Unassigned, Doorbell Pro, V3 but I can only use the
one license as when i select Edit Plan it still will only select one camera, not 2. Odd.
Guess I’ll have to wait out the Google Trial (already canceled the renewal) and see what happens as i reset and re-introduced both cameras but still only one camera is able to use Cam Plus regardless of showing 2 licenses.

Welcome to the User Community Forum @shaune!

Sorry you are having those issues. It does seem that the Trial licenses do cause a problem when trying to assign that cam over to a paid license.

I do not use any in app purchases for anything as I would rather buy directly from the Wyze Website and deal with them directly. So, I haven’t had any experience as to how the App Store licenses operate.

You are probably doing the best thing by waiting out the trial(s) until it expires. Post an update when it does!

@SlabSlayer thank you for the reply. I fixed the issue.

Because I am impatient I decided to try something different.
I saw a video by Wyze stating to reset camera(s) before selling
(which is an easier process then the competition’s) so I just removed
the devices from my app, signed out, created a new account (@Wyze.com)
using a different email address of mine. I then added the devices and said yes to the free 14 day
trial that pops up. Rinse & repeat to the second camera, and low and behold, both cameras
are now showing as they should with their respective trial license.
REMINDER: for those who are attempting this and still within the Google Play Store
Trial period, don’t forget to cancel it before it renews - this can be done via the Play
Store under the ‘Subscriptions’ tab.

1 Like

Hi there, yes purchased Thru iOS App Store, months and months, probably a almost a years worth of licenses.

Never knew to go directly on Wyze. My fault trusted Apple App Store and never really followed up with you.

For now on I will check with you first!

Thank you for being kind.

2 Likes

Are you currently having issues with your App Store Licenses?

Word from Wyze is that they are trying to work with the two app stores to try and get them to be more flexible. They have definitely caused more frustration than is necessary.

Yes I was, but I stopped everything for 1 month to see what happens.
It took a month or two to use up all my purchases from the iOS App Store, I don’t know how that happened but just out of them all now and waiting.

Then I guess go through WYZE directly?

I always recommend that users unassign their cams from the app store licenses just before they expire or they are cancelled.

There seems to be a trend of app store subs holding on to cams after the sub expires or is cancelled while still assigned.

But yes, if your subs have all expired and your cams are unassigned, you can go to your Wyze account at services.wyze.com and purchase your subs. They should then show up in your App Account → Services so you can reassign your cams to them.

1 Like

That’s what I did after realizing I should’ve gone through the web site after the 1st one I got through the app. All the rest were purchased through the site. This one will expires in Feb. and I plan on stopping that before going to the web site to renew it.

Thank you very much. I appreciate you clear wording. I will just go onto WYZE site directly and then assign from there.

Yes I agree they do hold on to them, and they talk about 3rd party apps, ok…

Have a good weekend.

Thank you,

Sometimes your not really sure and you just try.

Thank you also for your words. I appreciate the help.

You can only purchase subscriptions from the Wyze Website and manage your current subscriptions and payment method. Once purchased, assigning the cams to the license has to be done in the App: Account → Services

What 3rd party apps? Is this something the Apple App Store does? I have Android and don’t use the Google App Store for my Wyze subs, so I haven’t experienced this or read anything about it.

Hi again hope all is well,
Issue: cv3 to cam pro subscription with no connecting in the Wyze app.

I’m back again with the same issue I have had and you answered (thank you ) and advised me. I did what you recommended which was let all subscriptions run out, and then subscribe through the Wyze app. That’s what I did but I paid for it with my Apple Pay account. I thought that I was purchasing it directly from Wyze on my iPhone. Being right in with within the app. Not …
I have read before when someone else had it and did what they were told also, and still have the issue.
If I may please ask again?
I tried what you said and still have problems with new subscription I just purchased?
I have an apple and thought I was purchasing it directly from Wyze with Apple Pay ?
I can not assign my camera to
The subscription.
It keeps saying unassigned.
I have done this over and over not succeeding.
I’m not a newby with Wyze and reinstated my subscription after waiting for them to run out as advised, but cv3 to cam pro subscription no contracting in Wyze app.
Please advise, thank you

Didn’t use services.Wyze.com
Ok oh my, went off my phone on the app instead of directly going onto www.services@wyze.com

I will get back on that :confused:Thank you !

If you are forced to keep the Apple subs, You may need to goose your app to dump it’s old cache data and pull new data from the server:

  • Insure your App and your Cam Firmware are up to date.

  • Insure your CamPlus subscription is active in Account → Services and your Cam is assigned

  • Account → App Settings → Clear (Cache); Account → Sign Out; Close App; Force Close App from OS; Reopen App; test.

Didn’t help?

  • Unassign the cam from CP, close the app, reopen, reassign the cam to CP, test.

Didn’t help?

  • Unassign cam from CP; Delete cam from app; Clear Cache #3 above; reinstall cam; assign to CP; test.

Didn’t help?

Contact Customer Support

Thank you SlabSlayer and everyone for your information.

Re: The 3rd parties agencies are from the Apple App Store which sometimes take the money for the services, payments for purchases or subscriptions.
Apple tells you some purchases or subs are though them, the 3rd parties, and refunds depends on them… so I read on my apple phone information about how to go about asking for a refund, at times.
But I have been lucky with Apple App Store, very reachable.
So I think I’m reading.
So that being said, I don’t have to unassign them because they wouldn’t stay there, back and forth, back and forth. :face_with_raised_eyebrow:

I will go into the Wyze services through my browser instead of app and try it.

I will also do as you advise and let you know…
Thank you

Wyze, well sounds like they sell their subscriptions everywhere, even Amazon too?
Hmmm

If you purchased your subscription through your app, it was purchased from and controlled by Apple who is the 3rd party. It will show in your app Account → Services tab as such. Wyze website purchased subscriptions will say “Web” on them.

I don’t believe you will be able to see those subscriptions when you log into the Wyze Web Site Account Services page. I think those are only the subscriptions you purchase from Wyze directly. Someone here will correct me if I am wrong, I don’t have any app purchased subscriptions for this very reason, only Wyze website purchased subscriptions.

I’m not really sure what this means. Please elaborate.

Yes. Although the Amazon purchased subscriptions appear to be delivered as a redemption code to be activated within the Wyze Services Website rather than through an OS App Store.

I share the device only, not the service because it will allow me to designate service to the device, but as soon as I switch out and to next thing on the list, Wyze kicks it off, yes frustrating.

I have sent logs in, I have even purchased another subscription because I have cam out door and camv3, but just mainly use camv3.

I have even reached out to Apple regarding this, I have to check again but they know it’s happening, the deduct every month.

Ugh ok well I will cancel I guess, wait for credits because I have 2 now and go as you say Slayer on the web.

It’s Wyze services the web? I don’t want to sound stupid but it’s all web services.

I know my way around everything else in there that I use it for and know how to get what I want pretty much , well
Now except report card. You
Must have Cam Plus , I DO
HAVE IT, Repeated this how many times, it’s just not working.

So again I tried but a different way and still nothing it says.

Note: I am getting real short clips now were my normal was around 20-23 minutes. Now they are only 12/14 minutes?

1 Like