Hue Filament & Lamp Socket won't play nice

Hi Everyone,

I’m having some trouble with my Wyze Lamp Socket (a Wyze Cam v3 is connected). The very quick version of the problem is that I cannot get a Hue Filament bulb, plugged into the lamp socket, to stay off.

More details:

  • When I turn off the Hue bulb (with Hue app or Hue controller), I hear loud clicking from the socket and cam. Seconds later the bulb turns back on. This also seems to cause my cam to power cycle.
  • I have replicated the issue with a different Hue Filament bulb, different socket, different Wyze lamp socket, different Wyze Cam v.3, and with/without an SD card in the cam.
  • The issue is resolved if the USB port on the lamp socket is not in use, I replace the Hue Filament bulb with a regular Hue colour bulb* or dumb LED.
    (There are some issues if I use the power on/off function in the socket. Regular Hue controls work fine).
  • I tried everything in this thread.
  • It doesn’t matter what my power loss settings are for the Hue Bulb, the Filament bulbs always turn back on at 100% brightness.
  • I have triple checked my automations. I am pretty sure this isn’t anything I’ve set up acting wonky.
  • The power on/off function of the socket appears to do nothing when a Hue Filament bulb is plugged in.
  • I can’t set up a schedule or really control the lamp socket at all with the Wyze app when a Filament bulb is in.
  • All applications and firmware are up-to-date.

I took a couple videos of the light and camera power cycling. You should be able to hear the ticks and see the cam status light. If someone thinks it will be helpful, I can upload them.

Thanks for reading if you got this far :sweat_smile:

I figure if this doesn’t work I can always try a 3rd party USB lamp socket.


Update: I went outside today and found the colour Hue color bulb flashing and the camera offline. I switched the bulb off and on via the Hue app and everything started working as expected… :question:

I think you are radically over complicating things by trying to use the Hue bulb in the Wyze socket. Not even sure if using a Wyze bulb in the Wyze socket would really work. I think the intent of the socket was for just a regular bulb (LED or otherwise) and having the Hue or another smart bulb is probably interfering with the network connectivity of both the bulb and the socket. Have you tried an ordinary “stupid” bulb?

The Hue bulb was there before the Wyze socket and camera, so in terms of lighting I’m just trying to preserve the status quo if possible.

Per my original post, yes a dumb LED works fine:

The issue is resolved if the USB port on the lamp socket is not in use, I replace the Hue Filament bulb with a regular Hue colour bulb* or dumb LED.

I think you may be on to something in terms of network interference. After a bit of research it looks like Bluetooth. Zigbee, and WiFi spectrum overlaps. Time for more reading :nerd_face:

I was just about to say something along those lines. Without the camera there isn’t any networking or blue tooth or anything that would cause any interference. You just have a dumb socket.

Thanks for the help, I’ll try playing around with the frequencies a bit, but if that doesn’t work I think I’ll just power the cam from a outdoor outlet or buy a dumb USB socket adapter. Either way, I’ll report back here in case anyone else finds themselves in a similar position.

TL;DR: Use a power-only USB cable between the socket and cam.

I made an educated guess and tried a power-only usb cable. It worked so I converted my Wyze socket cable into a power-only one with a small piece of electrical tape over the data pins (two in the middle) on the USB A plug.

This turns your smart-socket into a dumb-socket. I’m fine with that as I only bought it as a way to supply power to the cam. I guess there must have been something odd going on with data transfer between the socket and cam when a Hue bulb was installed,

…and the problem has come back intermittently. I’m just going buy a outdoor USB adapter since it appear this was never meant to be.