How to use TinyCam Monitor Pro to view Wyzecam

I’m using TinyCam for all my cameras. I’m running the RTSP firmware on all but one and everything seems to work.

1 Like

Apologies for my ignorance, I am new to Wyze cams,

If Wyzecams run the RTSP (and be visible on Tinycam), can they still be viewed and managed on th Wyze App?

I will search for RTSP details and firmware on this forum

Thanks again @WildBill

1 Like

I am using an older version of TinyCam Pro and very old regular (not RTSP) Wyze firmware and everything is working just fine. (I expect this may change when Wyze pushes out forced updates.)

As long as you run TinyCam’s discovery module and then add your Wyze credentials to each camera it finds, you should be okay. How do your setup screens compare to those in the examples? Could you post one of your camera configs from TinyCam?

1 Like

The cams don’t run RTSP unless you install the RTSP firmware. Also, TinyCam doesn’t rely on RTSP to connect to the Wyze cams. It uses native connectivity.


my Google TV was connecting to an access-point which for whatever reason was blocking the connectivity

Connected google tv to the same network and tried, this time it worked,

thank you both @WildBill , @Customer

Note: wish I could mark both @WildBill & @Customer posts as solution… it only lets me choose one of them as solution…


Quite right - no need for RTSP as TinyCam is about the only 3rd part app that works with Wyze gear natively.

This is an older document someone put together that may help as well. The interface has changed a bit and there is now support for camera names instead of having to modify the “channel” for each camera. Just make sure the camera model is “Wyze Cam” and the brand is “Wyze Labs”.

Also beware there are some shady apps using the TinyCam name. The real one is Android only and uses that TinyCamMonitor URL.

Edit: oh geez you fixed it already! :slight_smile:

“No worries”


fixed, but with the help from you guys!!

members like yourself and wildbill really help this community and newbies like me :smiley:


I’m running NoxPlayer 7.0.19 on my Windows 11 Desktop HP-AIO. Have Wyze on TinyCam Pro on my smartphone with my WYZE cameras. I exported the setting thru Dropbox from my Smartphone to Dropbox on Nox Player and imported the setting saving me time. I run Wyze in a window in NoxPlayer running TnyCam Pro. Its been working well as another method to send WYZE to your desktop.

Been using TinyCam Pro for over a year. Seems after the last update on the base station for the outdoor cams I’m getting this error on all the outdoor ones.
““failed to connect (IOTC ER Device reject by wrong auth key)””
Anyone have any idea how to fix this?

I’m getting the exact same error with my Wyze Cam Outdoor.


All my other v2, v3 and pan cams are working. Firmware is updated, The tiny cam app is current on my FireTV.

It’s on Channel 1 and it is the first device in my Wyze app.


In current versions of TinyCam you can select cameras by UID instead of selecting a channel in Advanced settings.

Maybe that will provide you better results?

Thanks! Tried that. No joy. :slightly_frowning_face:

1 Like

I’m also getting the exact same error with my Wyze Cam Outdoor.
All my other cams are working. Firmware is updated, The tiny cam app is current on my Nvidia Shield.

Sigh, sounds as if someone needs to report this to the developer. :frowning:

Haven’t a clue how to do that…but TinyCam Pro is incredibly crash-prone on my FireStick 4K Max…plus this…I’m wondering if I should find a different application to show my Wyze cams on the Firestick? Not sure an alternative exists though…

Only if you install RTSP firmware on the cameras (or run the Wyze Docker Bridge somewhere else).

You can report the possible new bug / incompatibility to the author. His address is right on the support page and I’m told he responds.

Thanks, I emailed the developer all the details I could think of. We’ll see what happens.


It’s working on my Android phone now but not on FireStick.



1 Like

That did the trick for me. Thanks for the info.

1 Like