Help please! When app updated, my ROUTER disappeared. Still have internet but cannot add router & more!

First, my phone is old. Don’t know if that is part of the problem, however I just bought and set up router a few days ago.

I have internet but I can’t get the router to flash and added back to the app. I’ve tried doing a factory reset on the router (via the reset hole). My Canon Pixma will not autoconnect to the new router . . . AND

I want to rename the router (and choose an easier password to enter manually on the Canon which I have done repeatedly and apparently gotten wrong).

I want to love Wyze and be happy that I bought this router. I need help!

Could you clarify a few things?

Did the router ever show up in your app, or did it just start working when you plugged it in and you never went through the app setup?

Also, what app version are you on?

I was able to add it to the app before I set up my new modem and have had wireless since. When the app updated, the modem disappeared though my Wyze plug still shows up. Incidentally, I have been unable to get the plug to find the Wyze wireless/ I only use it in Winter so have been putting off troubleshooting it.

I don’t know where to find the version info. Not in the app & not in settings, at least as far as I can tell.

2.44.5 (3) Note: please tell Wyze that pastel colors very difficult to see for those of us with limited vision. I had to take a screen shot and then enlarge it to see the number.

I am not going to be helpful with this as I do not use iOS.

If you do a Factory Reset, you are going to have to install it again.

When you reinstall it, you can change the password. Keep in mind though that if you do this, every device on the network will need a new setup so that it can be supplied with the new password.

The Factory Reset does nothing other than make wireless disappear for a few minutes, then it comes back on without me doing anything.

I tried turning off the modem and router as is outlined in the steps but the router never had flashing lights and the app could not find it so, with power on (as I read was the way to do it), I pushed on the reset for several minutes. Nothing happened and I feared I was going to end up on the phone with Xfinity again but after several minutes, it started working!

The router reset process is a long one.

If it is up and running and you have WiFi, but it isn’t in your Home device list in the App, I’m not going to be much help since I don’t use iOS.

The best I can do is to suggest clearing the cache, signing out, closing the app, restarting the phone, and logging back in.

If that doesn’t work, delete the app and reinstall it.