Google Integration, which is not good, got even worst

Hi guys,

For quite some time already, Google home integration, which was not good due to a BIIIIG lag, got even worst: now, it doesn’t work anymore. Only show a message saying “Smart Home Camera” and that’s it.

My firmware version is, App version is 2.12.29 and plugin version is

I’ve chosen Wyze 8 months ago due to this integration, price and features but in the end, this never worked as supposed. I wanted to use the camera as a Baby Monitor but in the end, I have to use my cellphone as monitor…

Mine are the same as yours, I tried to reconnect Wyze in Google Home app and no change. The same camera works fine on Wyze app. The Google integration has never worked right, I agree the lag makes it worthless to use Google Hub. Wyze please fix this!
App version 2.12.29 firmware

1 Like

This happens for me when is use my Cromecast. That’s why I going to start using more Amazon products.

I just bought 4 plugs to be controlled by Google Home and while they setup fine on the Wyze app, I can’t get them to be setup on google home, and it’s taking me all day. On chat with Wyze support now for over 30 minutes and no closer.