Fixed long time disconnect problem by changing Wifi mode

I changed wifi mode from “b/g/n” mixed mode to “g” only. The more than one year long connection issue finally fixed for all 3 cams. Not sure if this only related to my Totolink-A6004NS router.

update: I am still using 2.4 and 5GHz on same router. The mode change is only for 2.4GHz.

Here’s the full story:

I have been using 3 cams (2 Cam Pan and 1 Cam) for more than 1 year. There’re occasional disconnect from time to time. For example working now, offline when checked few seconds later, then online again after few minutes. Their connectivity seems unstable compared with other brands of cams in same area. And it’s still quite frequent even with latest Aug firmware.

I wonder if there’re some router settings i overlooked. However the only official guideline about WYZE product is choosing a less crowded channel. I even thought it may be I were using them in Asia.

As the connection problem become more and more serious, I am almost considering buying new cams but still want to have a last try to fine tune my wifi on Totolink-A6004NS router.

After tried wifi whitelist, channel, and then “g” mode, Bingo!
(If there were “g” only mode I would definitely try it also.)

Every cams connected and streaming in just 1-2 seconds now and no more frequent error code or off-line black screen. It’s the expected performance for long time! I am so glad that it’s just like getting 3 brand new cams.

Hope it’s helpful for someone with same problem!


The Wyze cameras are 2.4 GHz only. In theory if an access point is dual band, they SHOULD work perfectly well only operating on 2.4 GHz. In reality, not so much. In the early Wyze camera days, there were LOTS of problems with Wyze cameras failing to connect to dual band access points. Firmware updates were made and it improved it, but the problem still shows up with some access points.

I have been around since the early days and could not reliably connect to my dual band access points - even if I set that SSID to 2.4 GHz only. Finally used some of my 2.4 GHz only access points to set up another SSID and the cameras connect to that just fine. So now, at my house there is a 2.4 GHz IoT SSID and a 5 GHz IoT SSID. They are the same LAN, but different WiFi SSIDs.


:+1: :+1: :+1: :100: :cowboy_hat_face: Excellent post

Good Job! You an amateur radio operator?

Yes, that is my amateur license. 43 years.


KC7HWA. (inactive now)

Something worth trying certainly, but the painfully obvious point to make is that 802.11b won’t do more than 11 Mbps max so setting that at the router / AP can severely limit much of your network. If it’s on its own SSID and the router allows others at full speed, great. Maybe something I should try!

Well I am still using both 2.4 and 5GHz on same router and “g mode only” is just for 2.4GHz. However it solved my problem.

Thanks for your reply. I made a typo, it’s “g” mode instead of “b” mode only. Yes it’s also my concern when change to “g only mode” for 2.4GHz. However all other devices like phone, pad and TV are still using 5GHz so they won’t be affected. Only Wyze cam and some IoT are using 2.4GHz.

When we are viewing individual Wyze cam, we can see the transmitting rate at top left corner. Even in “HD” mode, it’s just around 100kb/s. Thus 802.11b mode only would still be enough for 10 cams I guess.

802.11g only mode for my case should be more than enough.

1 Like

Well that makes more sense. :slight_smile:
I just double checked and the V2 supports b, g, or n. I wonder if hard coding the AP to “n” instead of “g” would make it equally stable. I’ve got to give it a try. I think most of my devices can do n? Hmm.

Well that didn’t help for me at all. :frowning:

Hard coded 802.11g and now I’m still losing the feed barely 1/2 hour in. Sometimes it can be restarted by tapping the refresh circle in the middle of the black screen, other times it fails back to the camera list,

Latest error was Connection has timed out, #20011

The camera is up during this problem, generating events including Alexa person detection. The viewing tablet happens to be using 802.11n on a different SSID on the LAN.

I may have found a simple fix. Running 12 hours overnight and still streaming. If this makes it through the day I’ll make a post about it.

1 Like

Sounds good looking forward to your sharing. There’re always untold secret in Wyze world :+1:

Well, it made it about 16 hours before failing (“connection failed”, no error number). A heck of a lot better than before, yet ultimately still disappointing. The change I tried was disabling IGMP in the ISP provided router settings.

And now it failed again within 20 minutes. I can’t get any consistent results. :frowning:

Customer, as I define ‘consistent’ you are getting them… Just not the ones you want. Consistent inconsistency