Firmware Upgrades * bricked cam

A month back in, while upgrading the firmware, it bricked one of my Pan Cams. I got in touch with Wyze who diligently tried to helped me restore it via a SD card flash was unsuccessful, and because it was out of warranty, I was pretty much out of luck. However this issue was weighing on me and I needed to find the root cause. It didn’t make sense as camera worked well, really well, up until the firmware upgrade, and it was not the first firmware upgrade either. Needless to say a month later I figured it out (or at least I think I did).

We all know that a sudden interruption in a middle of a firmware upgrade is never a good thing and in most cases will brick/break your devices. The problem in my case and for anyone who has a similar setup will most likely encounter this.

Daisy chaining your Wyze cams. It’s a great thing if you don’t want to occupy too many of your wall sockets. But here is the down fall. Let’s say You have 3 cams daisy chained (A, B and C) with Cam A as the direct power source plugged into the outlet, Cam B is powered by A, and Cam C is powered by Cam B. If you do a firmware upgrade to ALL the cams at the same time and say Cam A (which is your main power source) is the first to finish the upgrade and reboots, Cam B and C will lose power and therefore the upgrade is interrupted potentially causing a bricked cam. If Cam B reboots, Cam C will lose power. You get the idea.

If this is your set up, whether it’s 3 or 6 cams daisy chained I would recommend that you DO NOT do an upgrade to all devices at the same time. Instead do it individually to each cam unless they all have their own dedicated power source. I hope this helps.


I don’t use daisy chaining . I had no idea that the usb port lost power when one of the cameras restarted. There must be something I’m sure I’m missing even though you explained it very well.

1 Like

USB ports are not pass through so it is reliant on the device being active and turned on. Good test is to turn off your PC while your phone is charging through the USB ports. Once the pc is turned off your phone will not charge. So the same should apply to these cams. I am certain.


For a computer, this is understandable but not for a camera like Wyze which allows daisy chaining. I’m sure many people use daisy chaining system without knowing it. There should be warnings for these users. During the updates, we all know that we should not interrupt the power supply but not all know that the usb port will be disabled during the restart after a firmware update.

Thank you for sharing your experience, it will prevent several broken cameras after an update.:slightly_smiling_face:


Yes hopefully this post will help others and reach the ears of Wyze developers. Like all all technologies there are slight flaws and trial and error, but nonetheless I am still a huge fan of Wyze and excited for the new products they are releasing to consumers at fair prices.


Hi @ken.d and welcome to the community forum! :slightly_smiling_face:

There are a lot of ways the firmware flash to the camera doesn’t work. Most have bad cells on the uSD card. To test if its a corrupt uSD card.

  • Remove the uSD from the camera and test it in your workstation.
  • Check the disk with the command line C:\Windows\system32>ChkDsk X: /r Where X is the uSD card
  • Format the uSD card FAT32 and un-check the default “Quick” option so it can mask out bad cells.
    Note: The Format from the Wyze App is a Quick Format

Quick format just marks the partition as “formatted” and destroys the journal that keeps tracks of the files and their locations on hard drive.

Full format will clear files completely from the partition, rebuild the file system, volume label, and cluster size, and scans partition for logical bad sectors; that’s why full format is slower than quick format. Wyze devices must always use the FAT32 format.

The uSD card should be blank -and- No larger then 32Gb -and- formated FAT32
Next be sure you have unpacked the file and extracted the
demo_4.10.6.199.bin file. Then renamed it to demo.bin Some have renamed the .zip file instead.

  • Power off your camera and insert your microSD card.

  • Hold the setup button, plug in your USB cable, keep holding the setup button for 3-6 seconds until the light is solid blue, then release the button.

  • Note: The “Solid Blue” in this case is not the same as the one normally seen on the camera. Instead, both the blue and yellow LEDs will be on at once, making it appear to be a lighter blue.

  • Wait for 3-4 minutes. The camera will reboot and change light status during this time.

  • Once this is done, your camera should be functioning with the original setup. No need to re-setup your camera! :four_leaf_clover:


The Dr has spoken!

If it’s even possible to add anything whatso ever to that in-depth write up, is to double check that a .bin extention isn’t hidden by the OS. I renamed the demo file to demo.bin, not knowing that one .bin was already there, therefore now having a demo.bin.bin file that didn’t work.


You are correct again @Omgitstony. The default explorer display is to hide the File Name Extensions.
Apple: Checkbox labeled Hide extension Uncheck this box to have the Mac OS display this file.
Windoz File Explorer: Open View and Check the box that says File Name Extensions


Thanks Doc for the warm welcome. Yes I did follow the instructions to the tee. In fact the SD card is brand new, I bought it just for the sole purpose of trying to restore my pan cam. I’ve actually attempted it again with the Wyze technician on the phone but it just seemed like the cam didn’t go into its normal boot up. Unfortunately the tech gave up and offered to send a replacement. However I have quite a few Wyze cams and pan cams that I’ve purchased during the course of the past years and this one happens to be the one that is no longer under warranty. I ended up ordering a new one anyway, along with a preorder of the Wyze cam 3. So I am a little excited to try that one out. I just wanted to share this tidbit of info with others on this forum so they don’t go through what I went through.


Thanks @Omgitstony, all my files and file extensions are never hidden. I hate that it’s default, but that’s the first thing I do to all my PCs and laptops when I get them, I unhide everything.


Thank you for the feedback. Glad you’ve a solution. :slightly_smiling_face:
Yes, I unhide everything, too. :ok:
Looking forward to getting my V3 cam as well. :+1:


Thanks for the update! I should disable the hidden extentions. Never knew that hidden extentions was a thing until I tried flashing my first Wyze cam.

unnamed (1)


Sorry to hear about the bricking of the Pan Cam. I’ve had a situation similar to this with a V2 cam which was bricked by a bad firmware flash. Tried to flash to all versions on the site for V2 cams. Nothing worked until the very last version available to try. It was the version to convert the V2 cam to a web cam. It was the only firmware that worked. Once out of brick mode, I was able to flash it back to a V2 firmware to function correctly again.

1 Like

Hi @toyfountain and welcome to the community forum! :slightly_smiling_face:
Glad to hear you found a solution for the V2 firmware flash.
Sometimes you can reset the cam by going through the flash procedure w/o the uSD card installed, then flash again with the uSD in and the demo.bin file in place.

Thanks for sharing! I will give that method a try. I have nothing to lose at this point.

1 Like

Mine is still bricked I have tried all versions, none have worked to restore it. :rage:
Not seeing a download page you have to hunt thought forum posts. Not intuitive.

Hi @bingerson51 Here is a link to the download page: (
You can reset the cam by removing power, hold down the setup button with no uSD card installed and then plug in the power while continuing to hold the setup button until light is solid blue, then release the button.
Wait for 3-4 minutes. The camera will reboot and change light status during this time.

In the link @dr.know posted, the clickable links to download are the version numbers themselves.

1 Like

As @Omgitstony says re: version numbers. The file is actually a compressed ZIP file which has to be unpacked. Once the file is extracted it must be renamed before copy to uSD card and insert into cam.

So is the rename should be demo.bin ?

1 Like