Firmware update failed

I had the same problem, cam failed firmware update, got stuck with the yellow/blue blinking light, after a few emails with their team support they said it is a know issue and they ended up sending me a new cam and to dispose “accordingly” the bad unit; but I wonder if it can be fixed?? maybe they can release a computer software to wipe out all files and and perform a fresh installation. What do you think Wyze team??


me too. 2 out of 4 died. 2 wont reconnect after performing firmware update. Hard reset allows me to scan qr code but once scanned, the iPhone after a couple of minutes of trying says “connection failed”. This is most likely because the solid orange light goes off all together instead of becoming a flashing orange light, so guessing the wifi does not start up on the wyzecam.

<script src=“safari-extension://com.ebay.safari.myebaymanager-QYHMMGCMJR/c4780778/background/helpers/prefilterHelper.js” type=“text/javascript”></script><script src=“safari-extension://com.ebay.safari.myebaymanager-QYHMMGCMJR/c4780778/background/helpers/prefilterHelper.js” type=“text/javascript”></script>

My replacement arrived yesterday, brand new in box C1.

I did pause and think for a moment after powering it up and connecting it, when it asked if I wanted to update the firmware. It went fine.

They are sending a new camera to me. Hopefully that works fine.

Ditto. This sounds like a wide spread issue. I attempted to upgrade the firmware on 1 of my three cameras and not it’s unable to connect after the update. I tried to “factory reset” a bunch of times but still unable to go beyond the “code scanned” step.

I opened a ticket with support yesterday but no response yet. I hope there’s a fix for this.

im not geting a reply after 3 days? i am having the same problem

mine keeps rebooting!

Same problem 3 of my cameras will not go past “bar code scanned”. Sent a request to support. “They say the best test of a company’s product is the quality of their customer service.” Time will tell…

I too found that i was having firmware issues. The camera would fail when i tried to update the firmware from the IOS app. I was having a weird issue were i couldnt see the live feed but was still getting alerts saved to the cloud. I was able to download the latest firmware version onto my SD card and flash my camera. I havent had any issues since i did that.

I found the instructions here:

Also worth noting that i got this issue after i “piggy backed” my cameras (3). This was the last camera in the chain and i was using a usb extension to reach the area i wanted it hung at. Once flashed i still cannot see the live image while daisy chained with the USB extension but i can see it if its not on the USB extension. It would turn on and record to the SD card but I could NOT see the live footage. Long story short 2 should be the max to daisy chain with out any issues.

USB Extender:

[Wyze Ticket 186235] Request received: Camera is constantly rebooting after last firmware update

You may have to re flash the firmware:

1 Like

Thank you, I figured it out. What confused me was the latest version of
the firmware was not available. I re-flashed to the previous version
and then did the update again. Works fine now.


The solution works. Thanks Loki

just bought 2 cam.
1 cam had problem update firmware 2x.
then i decide to remove my SDcard.
update firmware successful 1st attempt.

Just wanted to share…I recently had an issue where all 3 of my wyze cam V2 suddenly stopped working with error code 90. Turns out that my Ethernet cable to my AP had gotten disconnect…Easy fix.

Support was good they got back to my within a day with instructions to check Ethernet, reset etc. However, during one of the cameras failed to update to the newest firmware(got interrupted). Multiple resets didn’t help. Would get to the QR Code Scanned phase but would never connect.

Wyze support came through again quickly with instructions on reflashing via the microSD card. Worked liked a charm and everything is back online now.

Great support and I won’t hesitate in buying the company’s products.

1 Like

KL, can you please explain how you reflashed via microSD.

1 Like

I have the same problem as most other people here. I had a camera within 20 feet of my wifi router that failed to update. Camera would not reconnect, so I removed it from the app and tried to repeat setup. Setup fails after the QR code scan with the device blinking blue/amber for awhile before rebooting and repeating that process.
I tried the manual firmware flash via a MicroSD card, but that also did not work. I tried both the current and most recent firmware releases, but in both cases, regardless of how long I held the setup button, it never went to a blue LED after plugging the camera in.
Any other ideas to try if the camera wont take a firmware update from the MicroSD card?

I am having the same problem loading the update. But there seems to be no reply on what to do to correct it.

Try this

1 Like