DNS via DHCP for WYZE Bulb Color

Just a heads up:

I learned if your first two DNS entries are not functioning properly when assigned by DHCP, the bulbs do not look at any additional DNS entries assigned by the scope. In other words, if you have more than two DNS entries assigned via your scope, the color bulbs disregard everything past the first two entries.

Trouble shooting this was a bit of a headache. All other WYZE cam devices in that DHCP scope worked just fine. Once I figured out my first two DNS entries in that DHCP scope were not working properly, I immediately knew the fix.

This is not uncommon with some devices. However, since all my other WYZE gear was working I am a bit shocked to learn the color bulbs are unique in this regard. With any luck this post will save someone some time and headaches if/when having connectivity issues with their color bulbs. If nothing else, it’s one more thing to check in your troubleshooting process.


1 Like

Could you elaborate on this. I am a network neophyte and need step by step instructions. I have five bulbs that will not update, However, I can reset them and control them. I just want all of my 12 bulbs on the same firmware.

Good day:

I’m not sure that I can add more detail than what is stated in the original post. If you have some bulbs updating and others that are not, the issue is unrelated to the information I provided in this thread.
(Assuming all bulbs are getting their IP assignments via the same DHCP server.)

The bulbs connect quickly without any problem and get an IP address. They just will NOT update. The other 7 bulbs work very well and very responsive. Before I open a ticket I wanted to make sure I was not doing anything wrong. I have ALL of my IOT’s on a dedicated 2.4 mesh network. Nothing else is on this network. No other devices are permitted to connect to that network. The bulbs that won’t upgrade have very poor response time as in seconds.

Hmm, have you tried unplugging one of the problematic bulbs and then plugging it back in? When you say very poor response times, what do you mean by that? As in ping times or do you mean when you change the color in the app it takes several seconds for the bulb to respond? Are the bulbs that have this issues close to one of your mesh access points or are they on the hairy edge of being out of range?

When I say poor response I am referring to command to execution time using the Wyze app. I just ran a speed test on my network with my phone and I got 13 ms ping, 1 ms jitter, and 543/41.5. I pay for 1.2 gig speed and wired I get over 900. My mesh network is 13 ms ping, 2ms jitter, and 95.1/39.8. My 5ghz separate network outside of mesh is at -39 dBm and the mesh network is at -42 dBm, which would only get better if I was standing next to the Unify Wireless Router which is optimized for latency. Not only did try plugging the bulbs back in, but also tried another light socket.

Three of the bulbs are stuck on Firmware version and the other two are stuck on
When I go through the reset procedure all five bulbs are immediately found and given a name. They come up as online and function albeit with an unacceptable delay as I stated earlier in this post. I checked the IP’s and all is good. The bulbs are immediately issued an IP number.

Taking it a step further I turned on the 2.4 radio on my other network and tried updating without the mesh network and a standard 192.168.1.xxx address. Same thing occurs. I am at wits end and about to open a ticket.

Finally, I took note that when I try to update the firmware on these bulbs, all five go offline. It makes me think that the update is being downloaded, but not able to take the update for some unknown reason.

Hmm, I think you’re likely going to have to open a ticket. If you’ve never worked with WYZE support before, I highly recommend you take a deep breath, set aside 2 hours (just in case) and then give them a call.

I figured it out. It is the Wyze software that is the issue. All five bulbs are updated successfully. You have to go to “Account/Firmware Update” to upgrade the firmware. You MUST ignore the other prompts including the bulb gear icon to update firmware.

Get this; I updated using my 5 Ghz network on my phone and just selected the mesh network and password to decommission the bulb. And, this was while my phone stayed on the 5 Ghz network. I would be it would also work off of the cellular network as well.

I have been fighting this for months and after each failure would put the bulbs in the closet until I would feel like torturing my self some more. I wonder how many other people have suffered this plight.

I took screen shots of the whole process and will in a few days or so, post it for others to take advantage of. In the meantime, I am wondering how to get them to fix their software. Your example of dealing with support is why I don’t want to call them.

Also, bulbs are now responsive like they should be.

1 Like