Detection Zone Not Working

I’m with you. I can’t see why anyone would purchase Wyze products when none of them have proven to work properly. Ever. And while customer service is friendly, they often have no solutions to the problems other than to send a log and say “we are working on it.” But it’s been over a year and I still have multiple unsolved problems. Literally, nothing has changed. In fact, I’d say the service has become worse over that time. Why do we even bother with them? Is it because we’ve invested so much money and time already? We should all just drop their service and go with a company that actually delivers on their promises, rather than increasing prices on a service that literally does not work.

The headlight glare is frustrating! But even worse, I have cars triggering recordings all day long even without glare. Just driving through the corner of the screen - where it’s grayed out - every time. Burning through battery on my camera like crazy. They claimed 6 months on a charge - hahahah!! Lucky if I can go 3 weeks. I’d tell you exactly but when I look at battery usage for my camera it says the last full charge was today. It wasn’t.

For those having detection zone issues, try giving your blocked-out zone an extra layer of blocked squares all around it.

From my understanding, the way the detection zone works is similar to that green motion tag that puts a big square around moving objects. Not everything inside the green square is actually moving, it will include some background area and the corners will extend a little bit beyond the moving object. The detection zone works similarly. If an object in motion would have the corner of the big square around it overlap into the detection zone area, even though there aren’t technically any pixels changing in that detection area, it will still trigger as movement because it was so close. So if you give a little buffer area of blocked out area then it should work a little more like what you are expecting it to do.

I keep buying them because they work fantastically for me. I have over 40 Wyze cams (and over 300 total Wyze devices), almost every camera model ever made, and they work great for their various use-cases.

It can take a little bit to understand the intricacies involved to perfect something for a particular environment with the various detection zone and sensitivity settings for each person, but once that is figured out, they usually work pretty well (providing a person has a good router, etc).

Try adding a little bit more of a buffer zone around the things you want blocked out and see if that helps. If you want some advice, post a screenshot of your current detection zone and where you keep having problems and some of us can give advice on what we would recommend trying and what has worked for us in similar situations.

I finally turned off zone detection and now just use Smart detections. Still get some annoying “talking” alerts when cars drive by and some minor “Person” detections for a shrub moving, but its better than zones that’s for sure.

The only way you can get zones to work is to capture a frame of the detection, put it in image software and look for pixels near the zone causing issues. Otherwise, you’ll need to buffer your zone with extra blocks.

Thanks for the advice. I will try that. Of course, I tried to bring up the detection zone settings and now my camera won’t even connect. It’s literally almost every day that I have issues with cameras. And by the way this is my third Wyze Outdoor Cam, the first two failed.

So here you can see there’s at least a full block buffer between where the car appears in the frame. Anything that moves on the street there triggers a recording. Any advice you might have would be appreciated, but it seems that no matter where the movement is, it records.

1 Like

Thank you! That is helpful.

Just for an experiment, will you add an EXTRA layer of blocked out grids in your yard and see if it makes any difference at all. I’m not asking you to do that permanently or anything, just run a temporary test and see if it makes any difference at all. I’m thinking something like this for a temporary test:

I’m not saying you’ll need to keep all of those blacked out, I just want to try this as a starting point and see what happens. If it works better, then we can start removing about half of those grids at a time until we find where the main conflict is. We can also potentially consider the sensitivity settings to try to maximize your detection zone area instead of having more blocked out. But lets just see how this changes things for you, and go from there with ways to make it better after that.


The motion tagging almost looks like its triggering on the white balance/exposure shift in the frame. The first motion tagging green box covers nearly the right 2/3 of the view.


I agree. It looks like the car is reflecting the sun into the camera, and thus triggering the motion event.


I’m LITERALLY having this same problem. In the “thumbnail” of the video clip preview, it shows there the motion is detected but then when I click on the video, there’s nothing there, OR what has been “detected” doesn’t get recorded until the event has already passed. It’s very frustrating and I’m glad I’m not the only one it’s happened too and I’m trying to figure out how to resolve it cuhz my phones just blown up with notifications and it’s picking up this tree I have blocked, help please lol

1 Like

I just bought two OG cams and they started going off the rails with notifications for NOTHING. Nothing is in the detection zone but komorebi. So does it want me to see how beautiful nature is or is Wyze punishing me for saying no to CamPlus? I had to turn off notification 3 times. However, I have the app on an old iPad which doesn’t see the OG cams but it does give me alerts from the OG cams. I’m talking about an alert every 5 minutes since 8 AM this morning. Which is way more than it was doing yesterday morning. Madness!

Thanks, just changed settings so we’ll see how it goes.

1 Like

It happens at night too. Don’t always even see a car or anything, just a flash of light in the corner and it’s recording

I have never been able to have detection zones work. I am always getting events recorded of people in the greyed out areas. I recently tried disabling motion tagging but it did not help. For me it useless.

1 Like

WRONG WRONG, most complaints are DETECTION ZONE SQUARES NOT SAVING! Shmitt errors happen after every “Firmware Update”. Sooo, to FIX this. Simply Delete your troubled WYZE CAM, add it again, scan, etc. BUT make sure you ADD CAM PLUS LITE, pick your"price", then return to your NOTIFICATIONS settings, turn on buttons, then check Detection Settings, reselect your SQUARES & SAVE. Worked likka Charm today 11/21/23​:partying_face::partying_face::partying_face::partying_face::partying_face::partying_face::partying_face:

1 Like

I have been dealing with this for at least w years now and I have done all that multiple times.
Please let us know if it is working reliability in a few days. It may work ok initially but is it reliable? In my experience it will screw up again.

1 Like

I’ve noticed that with my new Doorbell V2, it resets the motion detection zone to all-off (grayed) upon a reboot, or nightly.

It’s really annoying, considering that by it switching them to all-off it disables motion detection.

I shouldn’t have to delete my camera and rebuild all my settings every time there’s a frickin’ firmware update. I paid for these cameras and for Cam Plus so I expect a system that actually works. Just fix it please. It’s a joke that there are detection zones that don’t detect anything.

Yea sceew all that. Deleting and reinstalling and going through all that . They’ve increased rates twice in the last year and nothing has changed. I won’t be buying any more.

My detection is not working at all, it picks up ever car that goes by even though it is blocked out and even with extra squares blocked out.