When im home, i can view camera with no problems whatsoever,voice and everything works. When i leave my house and I go to the app. it trys to connect but it never can. THIS is the whole reason I bought this camera. it has literally been a paperweight since 5/21. I’ve sent a support ticket with my log. So i then brought the camera to my work. I set it up on their router, and the difference is it works here. I can view the camera when im not on wifi, i left work and was able to view my desk. Does ANYBODY have any advice for my situation? my best guess is that its my router but don’t understand what.

Yes, most likely the firewall or settings on your router. Hopefully support will be able to work with you to get it fixed.

I am again having the same problem, had worked great for a week.

i haven’t been able to remote view my camera since i bought it. Literally the only reason i got it.

lol this sucks

Check your home router for uPNP settings and enable them.

uPNP is a huge security risk. It would be much better to know what ports need to be opened for the camera to be accessible outside the lan.

uPNP is a security concern but it is that quickest method to debug the cause and then remedy it with a safer workaround for someone who doesn’t seem to be a techie.

Read the message, it says that it works at home on the wifi, so there is no problem with the router or anything at home. It’s the same with mine, It worked perfect for almost a year then its messed up now. When I am home it is flawless, as soon as I leave my wifi and on my 4G LTE, it tries but can’t connect. wth???

Do not double post. See my message on the other thread.