Can't get sprinkler schedule to work

@WyzeShanee please note; my schedule didn’t run this morning, I’ve made no changes to the schedule.

Submitted logs: 651302

You can see it is 10:04 and it was supposed to start at 10:00, and it isn’t running:

Library - 1 of 1

1 Like

I am writing a more detailed guide on Smart Schedule, btw.

1. Smart Schedule will dynamically change the schedule based on its parameters. For example, if you do a quick run, that can change the schedule since the soil moisture is now higher than expected. So the schedule will probably delay or shift to a different date.
2. Smart Schedule might still run if it’s raining - if the soil moisture of a zone is below 100%.
3. Check if Sprinkler Plus is activated. If you canceled or forgot to renew your subscription, Smart Schedule will not run even if it shows up on your app.

1 Like

Same issue here. New device, skips fixed daily schedules. Not using sprinkler+

Called Wyze, got a Return Material Authorization number and their Controller and Outdoor box are winging it’s way back to Washington. Not playing games with them.

Updated to beta firmware to 1.0.10 and it kept saying next run at 9.30pm while the time was already past 10pm. Rescheduled to 10:30pm and waiting

Hi @WyzeShanee, any updates on the fixed schedules not triggering?

Mine triggered automatically on Sunday, but not on Tuesday; without making any changes to the schedule, so it is really random.

As far as I can see there are a few distinct issues in this thread, namely:

  1. Fixed schedules not triggering; or only sometimes triggering
  2. Smart schedules not triggering
  3. Schedules triggering but not continuing to run or run at all
  4. and some variations of the above

For my case with the fixed schedules only sometimes triggering, could an issue with the Smart schedules or Sprinkler Plus be causing the issue? Should I reset and re-setup and not activate Sprinkler plus and try again?

Being a software developer myself, I cannot understand why issues with such a fundamentally core feature of the product is taking so long to fix. With the logs and information people have provided, it should be relatively straight forward to debug, reproduce and fix the issues. I kind of wish I could get my hands on the code myself, because I feel I’m putting more effort in to try figure out why it may not be working than it would be to debug.

Hoping to hear some positive news back.
Thank you!


Yes. As I mentioned before, what good is a smart controller if you have to check that it ran at every scheduled event? I’m very disappointed in this product. Especially after it worked fine last year.

Thanks @clivebor for the breakdown.

Smart Schedules have a complex algorithm which can cause schedules to dynamically change. In the logs I’ve checked on 1.0.10, most of the time the algorithm intentionally moved the schedule due to a quick run or weather change before the schedule, thus changing the plan last minute, For all other Smart or Fixed Schedules not running properly, there was a disconnection to WiFi.

For disconnection, we haven’t been able to confirm the reason. It could be distance from the router, random drops (my WiFi does this to my Mac once in a while), or something on the Wyze end. Possibly, it is a limitation of the chip since we have investigated our firmware development kit and haven’t found any causes for connectivity issues.


Even if the WiFi occasionally drops, why would the unit not automatically reset and reconnect or use the off-line schedule?

Have you looked into power supply issues. I installed mine with a higher wattage better regulated 24V AC supply then the one provided Wyze. It has worked well so far. When valves are activated they could cause an inductive power spike if the AC adapter is marginal. These spikes could temporarily disrupt the WiFi.

Is your firmware testing done with inductive valve loads attached to your test unit?

1 Like

Thanks for the response @WyzeShanee.

It definitely cannot be WiFi signal, because I have a Ubiquiti WiFi mesh setup, although what it could be is it swopping between 2 access points, I have seen it show up sometimes on the one access point and other times on the other as it is kind of in between the two; with about 80-90% signal on either.

What I will try is assign a specific SSID to one of the access points and connect the controller just to that SSID, that way it won’t switch between two.

To change the WiFi SSID the controller connects to; or password for that matter, is it required to re-setup the controller?

I would say the problem is not due to multiple access points. I (and I suspect many of us) only have a single WAP and still have the problem.

1 Like

I did receive this reply from Wyze support on a ticket that I opened up on July 12th. After following up with support, twice, they replied on July 20th:

First of all, I want to apologize for the experience you’ve had with the device. It’s not our usual standard. I’m sorry you’ve had to spend so much time on this. We also appreciate the time and efforts you have spent trying to work this out.

This is currently a known issue on the latest version of the Wyze app. We’ve reached out to the team and our developers are aware of this issue. Thanks to user reports like yours, our team is working towards a fix for this.

Although we do not currently have a timeline to share for when that fix may be available, we can offer a temporary workaround in the meantime. There is a new firmware currently being tested in beta that should offer improved schedules. Please feel free to join the beta program to utilize this beta firmware and add your voice to the conversation to continue improving this feature. You can find the steps to join the beta program here: Become a Beta Tester – Wyze"

So, according to this, it is a known problem with the most recent version of the Wyze App. I did reply and let them know that smart scheduling was still not consistently working for me on the beta firmware. But to update the thread here, for the last week, my smart schedule has been working normally (knock on wood.)

1 Like

Update on my experience with the .09/.10 beta.

Everything has been working as expected. I’ve been on the .09 and then .10 beta for 6 weeks and I’ve had no issues. My smart schedule is working without fault along with manual quick runs.

Then a week ago I did an overseeding so I ended the smart and set 3 fixed schedules throughout the day. Some use saturation and some use rain forecast to skip. They are all working as expected and the app is telling me if it skips and why. I’ve also done manual quick runs and they have never caused a schedule to fail.

I was also traveling a lot during this time and never had issue accessing it remotely and performing manual runs.

I still watch it closely, especially with new grass. But my confidence in the product is returning.

One other change I made since the beta install, that I don’t see others mention, is that I turned on the option to run the Wyze app in the background on my phone.

My sprinkler controller had been running normally for several weeks now, on the beta firmware. However, that ended this morning. I checked last night and the smart schedule was set to water this morning. It did not. Just pushed it a day, and says it will tomorrow. I submitted another log, #684339.

1 Like

Thanks for the info. Could you please help me confirm the log id one more time? I checked 684339 but it is led to a camera log.

sorry, the correct log ID is 684229

1 Like

Please add me to the beta as well. I requested in the app but not sure if that’s supposed to let me immediately download the beta firmware. By not being on beta, it only lets me go up to 1.0.1. Have had problems with the skipping and setting things (like root depth) but today it randomly turned on with no indication it was running and nothing in the history. I’m hoping the beta fixes that

I am now seeing that I should have been able to update past 1.0.1 according to the firmware change logs but there is no update available to me. Any help as to why this is? I joined the Beta and download the beta app but still no update. Under Beta it says “YOU’RE TESTING” followed by a blank list. Hitting Edit shows me Sprinkler is selected but saving doesn’t change anything

@DannyBoi It should be available on the official app, with no beta necessary.

Could you check the official app and see if an upgrade is available? If not, is your official app up to date?

I just deleted the beta app and redownloaded the official. It’s up to date. No update in the firmware section (only for one camera) and no ability to click the software version to check for an update like you can on the cameras.