Can't checkout for camplus?

It just says taking you to checkout. I’ve tried on my phone, home windows 11 pc on 2 different browsers and on my work windows 10 laptop, again on different browsers.


Didn’t work on the pc same as you windows 10 firefox, edge. was successful on the phone through the Android playstore. Had to enter payment details.

That’s strange, could you try to get a screen recording of this process?

Also, do you use a VPN on your network or devices? Could you try connecting to a diffrent network and checking out? Thanks!

Same. Tried VPN, different browsers, incognito, etc. I get the pulsing circle on a black screen that says, “taking you to checkout” indefinitely. Very frustrating!

1 Like

Same issue here. Customer service not helping or even acting like they understand what I’m saying. I’m starting to think they don’t want my money and I’m about to agree

Tried the website again today for a cam plus license, still doesn’t work on the website, only through the app on Android playstore.

I’d rather pay through the website,

Don’t have any experience with this issue, but with Wyze ALWAYS make sure you are on the most modern Wyze app or browser you can run.

I finally got it to work recently. I’m not sure this will work for everyone, but when first clicking on subscribe, DESELECT all of old cameras, and only select wyzecam v3 or other latest generation cameras. Doing this allowed me to finally get through checkout.

1 Like

cslewis17’s solution worked for me.