Can't add CMC service

I trialed the CMC service during beta and am trying to add it back to a cam right now. When I click ‘Add Service’ it does nothing. When I go to billing to ‘add card’ there isn’t a field for the CC number.

Anyone else having issues right now? Tried multiple browsers with no luck.

Just had a Roomba stolen off our porch so I’m adding more cams and trying to get CMC on them…

Are you adding the service here:

And are you logged in?

Yes and yes.

That officially stumps me! :face_with_monocle: I think you need to open a support ticket. I was able to modify the card on my account and add a new camera. I am guessing something is messed up on your account.

You can open a ticket here:

I opened a ticket before posting. I was just thinking there was something going on with their site and wanted to see if anyone else was having issues.

I assume it has something to do with when I ran a trial in beta. Thanks for checking it on your acct, Thanks!!

1 Like

I am having same issue…any way to resolve without opening a ticket?