Can't access cams or events

Hi. I hope I’m in the correct forum for this. As of this morning, I cannot access any of my cameras (I can tap and open them but there’s no actual feed) nor can I view any events. Any tips on getting this back up again? In fact, I can’t get to anything that is typically available in the app. Here is my info.

App is on Iphone 7 OS version 13.3.1
3 wyze cams (black) and one Wyze Pan Cam
Can’t get to the info in the app to get the firmware version
Using 2.4gz on a dual band wireless router
Cameras all located within 100 feet or less of router with nothing blocking (like a wall) in some cases and a wall in other cases

Everything has worked perfectly before today. In fact, it was working yesterday before I went to bed. Woke up this morning and can’t access anything on the app. I DO get notifications when the cameras see motion so I assume that means they are working.

I’m not sure why the image didn’t upload sorry, but it just shows the event screen with nothing on it. I did restart my router.

Me again. I think I have it figured out. I tried a different 2.4gz wifi connection and it now works so I can only assume there’s an issue on my end with the wifi.