Can't access cameras from outside my wifi

Anyone else having issues with the pixel 2 XL on Android 10 accessing cameras outside of the Wi-Fi?
When I’m home on Wi-Fi I can access the cameras no problem but when I turn the Wi-Fi off and use my cellular connection I cannot access the cameras. My wife has the OnePlus 6t and it works fine. I thought maybe it was because I’m was running the beta version of Android 10 and now the official release. I even factory reset my phone and still the same problem.

1 Like

I don’t know of anyone using Android 10 so I am not sure, did the issue start when you went to Android 10?

I’m guessing it probably started when I installed Android 10 beta 3 months ago.I was hoping it would be fixed now that Android 10 has been officially released.

I will do some hunting and see if there are any known issues with Android 10

I have Android 10 but I haven’t had any issues my pixel 3a… I’m still running the old app though. App v 2.4.82


I have Android 10/Pixel 3 and no issues with remote access,.

Have you had any luck? I have the same issue, Android 10 on a Pixel XL. I can connect over any Wi-Fi connection but not over mobile data. I’ve tried both the beta app and stable app, same problem. I sent my log files to wyze but no response.

When you turned in your support files did you do it through the app and if so was it the beta version or regular version you were using at the time.

I used the app which created a log file and attached it to an email in gmail with everything I typed in the app. It was with the beta app installed.

No luck here. It’s been about 6 months now. My wife still has no issues on the OnePlus 6t.

When you do that through the beta app that gets sent straight to the developers and you will usually not get any response. A support ticket through the website at the link below will generate a ticket number and get you a response from someone at WYZE.


Went ahead and created a ticket. We’ll see what happens,

I don’t know if this will help, but I got a response from support and my issue is gone! When I had updated to Android 10 I had also changed the DNS setting on my phone to connect to As soon as I disabled it I was able to connect to my cameras over mobile again.


That is good to know for future help in troubleshooting, Thank you for posting your fix.

Genius! That fixed it for me. So weird. Thank you!

1 Like

Glad I could help! I couldn’t imagine not having access to my cameras for six months. I just got another reply back from support and this is what they said:

I guess it’s a known issue but probably not widespread because a majority of people don’t change their phone’s DNS server.

1 Like

What’s funny is now that I know it’s a DNS issue and not an Android 10 issue a quick search for DNS popped up several other posts with the problem/fix in it. Still glad I found your post and was able to fix your problem!

Good to hear you found the solution! I have mind set to automatic which is the default I think.

I’m on Android 10 on my Pixel 1 and use a Private DNS called Quad 9 ( ). I am able to access both my WyzeCams when I am away from home wifi or wifi turned off and just on my mobile data plan.
On Android 10 I put the Private DNS provider hostname as “” as shown on Enable Private DNS using Quad9 on Android 9 | Quad9

Yeah I sometimes forget to check DNS settings since I tend to use a DNS service rather than the default from whatever router I’m connected to. When I used CloudFlare ( on my laptop I used to have issues when I connect to the local public library when Is asks for authentication for my library access/login, so I would just remove it temporarily to get access then put it back afterwards.

Also, come to think about it, for Cloudflare the Private DNS hostname to put in Android 10/9 is not but “” so that may also work to access Wyzecam while using a private DNS service.