Camv2 & CamPan video stream goes to internet and back rather than using LAN

Ive been using 3 different devices and 2 different softwares to monitor and configure my 2 Camv2 and 1 cam-pan-v2. My setup is as follows:

Asus Chromebox running Tinycam

Google Pixelbook (Chrome OS) running Tinycam

Pixel5 Android phone running both Tinycam and Wyxe app. Cell data and LAN.

Pixel3 Android phone running both Tinycam and Wyze app. No SIM or cell data, LAN only.

Using Century link router for internet access and Asus router for LAN.

Until about 2-3 weeks ago all was fine and monitoring the cams from any of the 3 devices with either software (Wyze app only runs on Pixel5 and Pixel3) and all video traffic was on my local LAN. Then I notices horrible performance with lagging video and all my other computer traffic was also very slow. I noticed that my available WAN upload speed of 0.7 Mbps (too slow for cloud use) and I tracked it down to the Wyze cams running on the 2 Chrome OS and Pixel3 devices but my pixel5 was still using the LAN for streaming as I expect. I’ve power cycled everything several times.

Tinycam reports strange IP addresses for my rather than on my LAN (192.168.1.x), although my Asus router reports them with correct LAN addresses on the devices that exhibit this problem. The Wyze app on either Pixel5 or Pixel3 reports correct LAN addresses whether exhibiting the problem or not. All devices except for the Pixel5 always show this problem. I’ve seen it occasionally on the Pixel5, but mostly it works OK with restarting the app or rebooting the cameras when it acts up.

This may not be a noticeable issue for someone with broadband. Since it seemed to happen on it’s own with my making any configuration changes, I’ve been kind of hoping an update would come out fixing it. Chrome OS had some major update issues during this time, but Google seems to have sorted that out. I think cam firmware, Android OS, Wyze app and tinycam also had updates around this time.

I want to buy a CamV3 or two, but I want to sort this out first. I’m stuck, please help.

Replying to myself as the problem seems fixed. In spite of several power cycles of all my devices, routers and clients, it would not resolve the problem. In my searches online I found mention of some router settings to avoid weird network issues. So I did two things to both my WAN and LAN routers.

  1. Turned off Quality of Service (QoS) filtering

  2. Set the DNS name servers to something other than my ISP provided ones (CenturyLink). I used Google’s, and

These settings caused both routers to warm reboot on their own and then everything was working again.

I’ve since ordered 3 Camv3 and one outdoor cam. If I ever get broadband I can use other Wyze services! I have my $100 down with Starlink (not yet available in my area) and fiber deplyment for my town is about 2 years out.